Can't update some packages, why?

– Please Write here your help request –
These packages are not updated by apt full-upgrade command, why?

aspnetcore-runtime-5.0/buster 5.0.11-1 amd64 [uppgraderingsbart från: 5.0.6-1]
dotnet-hostfxr-5.0/buster 5.0.11-1 amd64 [uppgraderingsbart från: 5.0.6-1]
dotnet-runtime-5.0/buster 5.0.11-1 amd64 [uppgraderingsbart från: 5.0.6-1]
dotnet-sdk-5.0/buster 5.0.402-1 amd64 [uppgraderingsbart från: 5.0.300-1]
firefox/rolling 93.0-1 amd64 [uppgraderingsbart från: 89.0-2]
laudanum/rolling 1.0+r36-0parrot1 all [uppgraderingsbart från: 1.0+r36-0kali4]
nishang/rolling 0.7.6-0parrot1 all [uppgraderingsbart från: 0.7.6-0kali2]
pack/rolling 0.0.4-0parrot1 all [uppgraderingsbart från: 0.0.4-0kali4]
regripper/rolling 2.5-1parrot1 amd64 [uppgraderingsbart från: 2.5-1kali0]
webshells/rolling 1.1+parrot1 all [uppgraderingsbart från: 1.1+kali6]

only used the build in update function and apt update && apt full-upgrade but this happens once in a while and only a full reinstall of the Parrot OS seems to solve this. This is one of the annoying things with this brand of Linux.

Any suggestions how to fix this?

2 Likes

Yes even i am running into the same issue…please help…these 4 packages show up in the upgrade list but when i run upgrade command it does nothing. instead tells to run sudo apt list --upgradable and also i am running into error realtek.

laudanum/rolling 1.0+r36-0parrot1 all [upgradable from: 1.0+r36-0kali4]
nishang/rolling 0.7.6-0parrot1 all [upgradable from: 0.7.6-0kali2]
pack/rolling 0.0.4-0parrot1 all [upgradable from: 0.0.4-0kali4]
webshells/rolling 1.1+parrot1 all [upgradable from: 1.1+kali6]

1 Like

When you try to update one of these packages, the reason appears:

The following packages have unmet dependencies:
laudanum : Depends: kali-defaults but it is not installable

I’m looking for a solution.

Same problem here…

laudanum/rolling 1.0+r36-0parrot1 all [actualizable desde: 1.0+r36-0kali4]
nishang/rolling 0.7.6-0parrot1 all [actualizable desde: 0.7.6-0kali2]
pack/rolling 0.0.4-0parrot1 all [actualizable desde: 0.0.4-0kali3]
webshells/rolling 1.1+parrot1 all [actualizable desde: 1.1+kali6]

Add the Kali Linux repository and it worked, but two files appear that were in the Parrot and Kaly repository, I could not get it to install because it is in both repos