Can't upgrade via apt or parrot-upgrade

Hey folks,
I’m running Parrot OS in a virtual machine and updated it regularly with “parrot-upgrade”.
Recently I get the error that there are unmet dependencies in wine and some packages are hold back.
I already tried unholding the 4 packages, did a fresh install of wine and tried to solve it with “Synaptic Package Manager”, but nothing helped.
Does someone know a solution or something I could try? (Snapshot exists, I can always revert to this stage)

Thanks and best regards,

First run sudo apt-get update.then run sudo apt-get upgrade.

Have you tried?

sudo apt clean;
sudo dpkg --configure -a;
sudo apt install -f;

I think you are not aware about Parrot OS as a rolling distro.
Please read this documentation:

Try removing wine completely then Upgrade the system using sudo parrot-upgrade

you can use : sudo apt autoremove --purge wine
:exclamation:1. this will remove each and every file including configrations related to wine package.:exclamation:
:exclamation:2. Do Not Make mistake while using this command because this can Purge the system too.:exclamation:


Thank you very much. It worked! :slight_smile:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.