Can't use a usb wifi adapter...

Briefly describe your issue below:
Hey. I have recently installed ParrotSec and buyed a usb wifi-adaptor. I have conected it to the computer, but when i taken the drivers and tried the command: sudo make It didnt work. Here is the output too:

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Version: ParrotSec GNU/Linux 4.8
Architecture: amd64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian GTK

Configured to multiboot with other systems? (yes / no)

No

List your hardware specs to include make, model and firmware (when applicable):

HP-650 Notebook Laptop

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
https://pastebin.com/KZCRwDX1

Did you read the readme for Linux for this wifi adapter?

What model is the hardware chip?

It does not have a readme for linux, only for windows. But it says that it has support for linux…

You should try searching the WiFi adapter model.
try ‘lsusb’
search if the firmware are avaliable in the repository
with ‘apt-cache search <name_of_firmware>’
then install with ‘apt install <firmware_package_name>’

1 Like

Thanks. I have found the drivers on the web, but when i do sudo make is outputing this: ┌─[✗]─[parrot@parrot]─[~/Downloads/DPO_MT7601U_LinuxSTA_3.0.0.4_20130913]
└──╼ $sudo make
make -C tools
make[1]: Entering directory ‘/home/parrot/Downloads/DPO_MT7601U_LinuxSTA_3.0.0.4_20130913/tools’
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory ‘/home/parrot/Downloads/DPO_MT7601U_LinuxSTA_3.0.0.4_20130913/tools’
/home/parrot/Downloads/DPO_MT7601U_LinuxSTA_3.0.0.4_20130913/tools/bin2h
cp -f os/linux/Makefile.6 /home/parrot/Downloads/DPO_MT7601U_LinuxSTA_3.0.0.4_20130913/os/linux/Makefile
make -C /lib/modules/5.4.0-4parrot1-amd64/build SUBDIRS=/home/parrot/Downloads/DPO_MT7601U_LinuxSTA_3.0.0.4_20130913/os/linux modules
make[1]: Entering directory ‘/usr/src/linux-headers-5.4.0-4parrot1-amd64’
***
***The source tree is not clean, please run ‘make mrproper’
***in /usr/src/linux-headers-5.4.0-4parrot1-common`
***
make[3]: *** [/usr/src/linux-headers-5.4.0-4parrot1-common/Makefile:511: outputmakefile] Error 1
/usr/src/linux-headers-5.4.0-4parrot1-common/Makefile:659: include/config/auto.conf.cmd: No such file or directory
make[2]: *** [/usr/src/linux-headers-5.4.0-4parrot1-common/Makefile:677: include/config/auto.conf.cmd] Error 2
make[1]: *** [/usr/src/linux-headers-5.4.0-4parrot1-common/Makefile:179: sub-make] Error 2
make[1]: Leaving directory ‘/usr/src/linux-headers-5.4.0-4parrot1-amd64’
make: *** [Makefile:395: LINUX] Error 2

Here is The output on PasteBin: https://pastebin.com/TZfPiLDK
Please help me… Also, when i do sudo make mrproper in /usr/src/linux-headers-5.4.0-4parrot1-common it says this:
┌─[parrot@parrot]─[/usr/src/linux-headers-5.4.0-4parrot1-common]
└──╼ $sudo make mrproper
scripts/Makefile.clean:15: Documentation/Makefile: No such file or directory
make[1]: *** No rule to make target ‘Documentation/Makefile’. Stop.
make: *** [Makefile:1670: _clean_Documentation] Error 2

Oh and yes, the firmware is in the repository:
$apt-cache search MT7601U
firmware-misc-nonfree - Binary firmware for various drivers in the Linux kernel

As mentioned search the repository for the chip driver after installing (exact version of Linux kernel) headers.

Then:

sudo modprobe DriverNameHere

How do i see the linux version i am running?

uname -a

Oh and here is the output of sudo dmesg…output.log (86.4 KB)
And output of uname -a:
┌─[parrot@parrot]─[~]
└──╼ $uname -a
Linux parrot 5.4.0-4parrot1-amd64 #1 SMP Parrot 5.4.19-4parrot1 (2020-02-27) x86_64 GNU/Linux

I have installed the exact version of linux kernel headers by using the command sudo apt-get install linux-headers-$(uname -r). Nothing worked, same issue and the headers where already installed.I think that there is a problem with my linux-headers folder, because A LOT of files are missing…(Output of ls /usr/src/linux-headers-$(uname -r): arch, include, Makefile, Module.symvers, scripts, tools… Pls help me i am trying this for a week…