Certificate verification failed

Briefly describe your issue below:

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

PRETTY_NAME=“Parrot GNU/Linux 4.9”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.9”
VERSION_ID=“4.9”

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian Standard

Configured to multiboot with other systems? (yes / no)

No

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Pls help me to solve this problem. I still can’t upgrade my parrot since this happen. I have tried read at parrot guide but still no solutions. Search the internet for any similar problem still nothing… hope someone can give me way out from this…

Command i used:

sudo apt-get update && sudo apt full-upgrade -y.

Below is the script i get from the command:

Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate. Could not handshake: Error in the certificate verification. [IP: 2406:f000:30f0::200 443]

i assume https://support.sectigo.com/Com_KnowledgeDetailPage?Id=kA03l00000117LT is the issue.

So i just need to download the cert file and manually onstall to my pc?

No ,(*if its the issue i mentioned above^ then the following applies) this is a server sided problem ,the Certificate on the server needs to be updated ,& this can only be done by the Server Administrator.

@palinuro , @tissy could you provide some response on this issue?

Temporarily change your mirror or reset it to default and then try to update the system using sudo parrot-upgrade
source:https://docs.parrotlinux.org/faq/#how-do-i-upgrade-my-system

The user is using the singapore mirror. Seems that is giving problems to many users. Try to change mirror and let us know.

Great. It works now after changing the mirror. Thanks for the help.