Changing keyboard layout under live ISO


I have some problem with choosing the right keyboard layout in the live enviroment. If i choose my layout in the setings, like german, after a couple of minutes it changes back to english layout, even if is et it with setxkbmap. Doed there someone other people who observed same behaviour?

Thanks any help!


maybe loadkeys us or fr ??

Thanks! Should i use it like just like loadkeys de? Because it doesn’t work, It says: “Couldn’t get a filedescriptor referring to the console”. I tried the folders to look for keymaps files listed under man loadkeys, but there is no such folders (/usr/share/kbd/keymaps & /usr/src/linux/drivers/char/

localectl status (to see the configuration)


loadkeys gr
loadkeys gr-pc
dpkg-reconfigure keyboard-configuration


go menu keybord
choose your keyboard model and add your keyboard layout
and in the terminal if the change has not already been made type dpkg-reconfigure keyboard-configuration


just change your location to German and your keyboard should automatically configure itself

localectl set-locale LANG=fr_FR.utf8
localectl set-keymap fr-latin9
localectl set-x11-keymap fr

set in germany :wink:

Thanks for the tips! Unfortunately none of them working. I went through with the settings with dpkg-reconfigure keyboard-configuration command as root and as sudo also, but the layout stayed in english.
If i use TAB after typing localectl set-keymap commad, it says “Failed to read list of keymaps: no such file or directory”. The only way to change the keyboard, is setxkbmap de, but after a couple of minutes the layout changes back to english. If i set the layout in settings, it stays in english, no matter of what i set for it.

Don t worry see you tomorrow :wink:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.