codium clumn selection mode

Hello,

I can not column select in Codium editor using keyboard (Shift+Option) and mouse. Parrot is running Mate Desktop in Parallels on Macbook pro. I am able to select in a VSCode instance on a Debian Buster VM.

When I switch Codium to “column selection” mode, it works as intended, but in keyboard/mouse mode of column selecting, Mate desktop seems to interfere (Alt gets it into “Window Move” mode).

So, I found System → Control Center → Look and Feel → Windows → Behavior → Movement Key, and switched from Alt to Super. This has disabled the window movement mode when I press Shift+Alt, but the selection still does not work. All column-selecton-related settings are identical between Codium on Parrot and VSCode on Buster.

If anyone knows a secret recipe to make this work, I would appreciate it very much - it may seem like a small thing, but it is very annoying. Otherwise, I like Parrot a lot, not sure how hard it is to switch the window manager if I don’t find the way to reconcile Mate with Codium.

Thanks

  • ParrotOS iso in use:

Parrot-security-5.0_amd64.iso

  • Application used for flashing the iso:

Downloaded

  • Logs/Terminal output (use pastebin or similar services):

  • Screenshots:

The hotkey on Linux version is Ctrl + Shift.

It’s working here

Thanks for responding, but that’s not working for me, either. I have selected “Selection → Switch to Ctrl+Click for Multi-Cursor” but on selection attempt I get a cut/copy/paste popup menu:

Switched to vscode - works out of the box