Could not find the program `konsole`

Why is the administration not responding when there will be an update ???

@dmknght @tissy @I_Have_Treasure Then when we get next update of KDE Framework 5.71?

joining the question

Dudes, all this pressure. Fine, ask the question but leave those that do in peace, be patient or fix it yourself! Better still just enter command in Terminal and by the time things are corrected you might even have forgotten about icon initiated programs!!
Take The Slow Life
bing

2 Likes

does this problem have a solution?

Guys, the program Konsole is correctly installed in Parrot. The actual workaround to launch it is to open a terminal and launch Konsole. :woman_shrugging: :woman_shrugging:
Kde team fixed the bug, but we’re waiting for Debian-side update for this.

2 Likes

What you need to do, is go to your settings, go to where the default applications stuff is, change it from konsole to another application, and type /usr/bin/konsole, then it will launch the konsole correctly.

3 Likes

I have done it, and it seems to work.
It’s just the path in settings was not specified for it I believe

Funciona!
bing

Well they get Anonymous part fixed now none of the programs on pentest work. Come on guys this is the 3rd version of Parrot that I have downloaded that everything don’t wok out of the box. What has changed? Meaning from the beginning this used to be such a bad ass OS.


Funciona!
good

Watch this…!

1 Like

Update on the /usr/bin/konsole. I have kept it like this in the settings, and I have not had any problems with stuff opening with konsole. I think this is a path problem in the design on the system. Granted, I’m not a computer expert, I’m still learning, but this just seems to me a path problem. Once again, I put /usr/bin/konsole in Settings > Applications > Default Applications > Terminal Emulator > Use a different terminal program and put /usr/bin/konsole

1 Like

I just stripped KDE down but when it was installed 2 days ago I had no issues opening Konsole. I don’t prefer Konsole and never keep it though. I find it weird how people are just sticking with the default given software on a Linux distro. I understand keeping it simple but the whole reason I switched from Windows is because I love customizing and creating my own enviornment for my many different use cases. My point is people shouldn’t be stuck on a bug over a specific terminal when Linux gives us so many options

I think the issue with Konsole is resolved but I haven’t came across any bugs I can’t fix. It even prompts you to not install KDE right now on the downloads page but I did it anyway and everything opened up just fine

1 Like

that bug is still there
kde has updated the patch
and parrot developers are waiting for debian to catch the patch and release it
as you suggested, only people with konsole as default terminal are facing the issue
which can be easily fixed by manually specifying the konsole location i.e. /usr/bin/konsole

1 Like

i also this bug how can i overcome from this bug

manually specify the location of konsole

go to

System settings > Applications > Default Application > Terminal Emulator
Select select different terminal program and add "/usr/bin/konsole "

This will resolve the problem

Thank you. Konsole team also fixed that bug few months ago. A bug report was opened on Debian side and we are waiting for update from Debian.

Yep issue resolved. I think is that button in Default App settings, something is wrong when you press default terminal Konsole. Anyway just by adding /usr/bin/konsole solved this problem. Thanks guys.