cryptsetup: Waiting on encrypted source device

Briefly describe your issue below:
When booting it comes up with cryptsetup: waiting on ecrypted source device uuid then a string of numbers and letter.

Nothings has changed, it was working fine before so I’m not sure what’s caused this.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Latest one on 64bit

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Live install to external HHD, then added encrypted persisitance

Configured to multiboot with other systems? (yes / no)
yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Something has had to change for this…

Did you do an upgrade? Did you mess around with the partitions or anything in /etc directory?

Did it happen after the first time you ran windows after setting up the dual boot? (and then tried to boot Parrot)

Heya, sorry for the late response I’m working nights.

The way I did it was to make a live USB to my external HDD, and then add persistence using this guide:

Although I do remember last time I ran it, I installed Fat RAT which is part of a udemy course i’m doing. Surely this couldn’t be it?

I did it this way because everytime I tried to do a proper install to the external hard drive, it’d fail.

From my very very limited experience, I’d say the partition labels have been changed some how. So if it’s looking for sda, and sda has been changed to sdb, then this may be an issue?