Current Parrot GPG Key?

I installed Parrot Security 4.4 32-bit on an old netbook hoping to maybe upgrade the distro to 4.11.3 or even 5.0 Beta.

When I do a

sudo parrot-upgrade

I’m told the repo(s) are not signed and can’t be verified because the public key is not available. The last post in this community about the proper GPG key did not fix this: Can’t update due to no gpg key

I’ve tried a number of imports based on stuff I’ve found on this community and by Googling. Does anyone know what the (current?) key is? Thanks!

sudo apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 363A96A5CEA9EA27
sudo apt-key adv --keyserver ha.pool.sks-keyservers.net --recv-keys 363A96A5CEA9EA27
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 71EB474019940E11
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3B4FE6ACC0B21F32
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys C7B39D0362972489
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B56FFA946EB1660A
wget -q -O - https://deb.parrotsec.org/parrot/misc/parrotsec.gpg | sudo gpg --import
wget -qO - https://archive.parrotsec.org/parrot/misc/parrotsec.gpg | sudo apt-key add -
wget -qO - https://deb.parrot.sh/parrot/misc/misc/parrotsec.gpg | sudo apt-key add -

Hi. You should find them here: Index of /parrot/misc/misc/

However, I suggest you not to use that trick to install Parrot. Have you already tried to install Parrot 4.11.3 directly? The passage between one edition and another could lead to problems that can be difficult to solve.

1 Like

Thanks @danterolle!

I was able to download the key, having to use http instead of https, and successfully apt-key added it.

This is the last 32-bit/x86 Parrot 4.4 which I was hoping to upgrade and run on an old netbook

Unfortunately lots of packages to be downgraded, removed, upgraded, installed and unchanged. Synaptic (and parrot-upgrade) won’t let me do much, mainly due to libc6-dev breaking libgcc-8-dev. I’ll fool around with it a little more before installing something else. I have an old USB 2.0 drive using Ventoy I try to keep the latest or last versions of 32-bit Linux distros on.

what cpu do you have? could you give me the exact model?

Hi Lorenzo!

Acer Aspire One Model 150. N270 Atom processor @1.6 GHz. 1.5 GB RAM.

It was a fool’s errand. Was hoping to get Parrot x86 working on this thing instead of resorting to Kali x86 again. (I usually use an ISO with OpenBox as the default WM to keep the memory footprint to under 150 MB.)

i have a good news for you. parrot 5.0 will support i386 again, but we will not provide live images by default, only the architect edition will be installable

my suggestion for you is to install the debian base system (no gui), install the parrot-archive-keyring package and then switch to the parrot repo deb Index of /parrot/ parrot main contrib non-free

few system upgrades and reboots and you will have your 32bit x86 parrot system. you can install the parrot interface with the parrot-interface package, and the parrot tools with the various parrot-tools-* package family

2 Likes

Wow! This is unexpected and exciting! Many thanks! :smiley:

I’ll try it today if this is possible right now. I already have the base Debian mini ISO downloaded.

Hi. I installed Debian Sid (mini.iso => Advanced Install => sid repo) with no desktop. I still can’t get the proper key installed.

sudo nano /etc/apt/sources.list =>

https://deb.parrot.sh/parrot parrot main contrib non-free

or is it

https://deb.parrot.sh/parrot rolling main contrib non-free

Then these all failed…

The usual issues of “is not signed”, “signatures couldn’t be verified”, etc.

I also tried

wget https://deb.parrot.sh/parrot/pool/main/p/parrot-archive-keyring/parrot-archive-keyring_2021.7%2Bparrot1_all.deb
sudo dpkg -i parrot-archive-keyring_2021.7+parrot1_all.deb 
Error: "...is not a Debian format archive"

Ah! New Parrot 5 Beta 3 with an i386 ISO! Installing now using VirtualBox (first).

Parrot-architect-5.0-beta3_i386.iso 320.0 MiB 2022-Jan-28 22:34
Parrot-architect-5.0-beta3_i386.iso.torrent 9.5 KiB 2022-Jan-28 23:45