Default /boot for Guided Encrypted LVM

So ive been using parrotsec for a decent time now (About 10 months)
Loved it.

Apart from one thing.
While installing it, Keep in mind i was new to linux, I had to encrypt my 1TB Harddrive to make sure my data remains safe.

So, i had to go for “Guided Encrypted LVM” option while installing.
It gave me 8GB swap and 200MB /boot space. I went for that option hoping that it would guide me and think whats best for my system that had 8GB Ram. i7 and 1TB HDD. Brand New Device. Untouched. DOS on HDD and rest space compelety vacant.

Im not sure if thats the default boot space all linux distro provide while using guided but 200Mb DOES NOT WORK.

Every few months, parrot pushes updates (which is good and preferable) but it messes up my /boot. I keep getting prompt that my boot space is 0mb or 2mb and i need to clear up some things.

Im not really sure what to remove as once i ended up bricking my machine (maybe deleted wrong image file or something similar.)
Thats not a major issue. The major issue is im unable to update any further after a certain amount of updates since there isnt any space left in /boot

Then it keeps giving me errors when i run apt autoremove. Im sure @KidKlown & @s1udge are we aware of those issues :stuck_out_tongue:

If possible, Please increase the default /boot space to atleast 512Mb when someone is installing via Guided Encrypted LVM to avoid any further/similar issues someone may have in future :slight_smile:

Since 4.4 the boot partition has been larger. I’m not sure the exact size off the top of my head. https://www.parrotsec.org/blog/parrot-4-4-release-notes/

And remember you should be able to clean out you /boot using the command i gave you before

sudo apt-get purge $(echo $(dpkg -l | grep -e “ii linux-image-[0-9]” | grep -v $(uname -r) -m 1 | cut -d' ' -f3))

It is because /boot partition keep installing new kernel without removing old kernel versions. It has nothing with “encrypted LVM” because both encrypted and unencrypted disk can have this problem

@dmknght
So thafs my point. By default the guided setup provides /boot with less then 256mb even for 1TB HDD . Which isnt really comfortable as it may cause issues in future for several users who are new to Linux and depend on apt autoremove command to clean the /boot of obsolete files rather than a long complicated command that a new linux user may try and end up bricking their own device.

My whole point was to increase the /boot size to atleast 512MB by default in guided installation.

I did use it :slight_smile: :heart: Thank You. PS the command initially gave me an error so i switched to single quote for ‘ii linux-image-[0-9]’ instead of double quotes and it worked.

I wanted to know if using the command you gave me when /boot gives me trouble…is that safe? Because i do not want to brick my machines since it has a lot of important data of which i do not have backup of.

1 Like

You can use
apt search linux-image* | grep installed
and apt search linux-header* | grep installed
then select package to remove. (if you don’t know much about bash scripting).

1 Like

If you removed all boot information accidently, you can still reinstall boot partition via chroot in live mode from usb.

1 Like

(I don’t, But Im learning)

Lets say for instance i ran the command you have me.
The output after running it was

└──╼ $apt search linux-image* | grep installed

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.


linux-headers-4.19.37-parrot1-amd64/stable,now 4.19.37-5parrot1 amd64 [installed,automatic]
linux-headers-5.1.0-parrot1-3t-amd64/now 5.1.3-1parrot1.3t amd64 [installed,local]
linux-image-4.19.37-parrot1-amd64/stable,now 4.19.37-5parrot1 amd64 [installed,automatic]
linux-image-5.1.0-parrot1-3t-amd64/now 5.1.3-1parrot1.3t amd64 [installed,local]
linux-image-amd64/stable,now 4.19.37+110+parrot1 amd64 [installed]

How do i identify and make a decision if there is something i need to remove or if theres anything at all to remove.

Coming back to the Original issue of this thread.

@dmknght Is it possible for the Devs to increase the default /boot space in guided install to atleast upto 512Mb or better yer 1024Mb. I know 1024Mb is a bit overkill but by having less than 256Mb in a 1TB brand new Harddrive by default in /boot via guided Encrypted LVM install is causing a bunch of trouble over a period of time. At least pull a request and see how they respond to such situation becuase for a new linux user like me who does not have much knowledge in Linux computing, would rather prefer not to tamper /boot user all sorts of commands as a superuser.

Last week Thanks to @KidKlown I solved the issue with his help, But this week after an update i got a new issue, as usual

└──╼ $sudo apt autoremove
[sudo] password for user: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up initramfs-tools (0.133) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.133) ...
update-initramfs: Generating /boot/initrd.img-5.1.0-parrot1-3t-amd64
pigz: abort: write error on <stdout> (No space left on device)
E: mkinitramfs failure cpio 141 pigz 28
update-initramfs: failed for /boot/initrd.img-5.1.0-parrot1-3t-amd64 with 1.
dpkg: error processing package initramfs-tools (--configure):
 installed initramfs-tools package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 initramfs-tools
Configuring sandbox profiles....
Sandbox profiles updated!
Scanning application launchers
Updating active launchers
Done
E: Sub-process /usr/bin/dpkg returned an error code (1)

Will be running the command i was provided by @KidKlown (Thanks again :slight_smile:) and hope that it works, at least for now.

If you want to remove kernel 5.1, you have to boot as other kernel version. Current stable version is 4.19.37. You can do it in advanced boot option.
The /boot/ size depends on how you created partitions. If you want to increase partition’s size, you have to do it manually. I believe gparted supports this kind of problem but it takes time.

@dmknght I think i cleared myself a couple of times already in above replies. I used the guided encrypted LVM install which gave me a tiny /boot/ size by default on a brand new HDD. For instance, If I, a new linux user, who just wants a simple encrypted install for basic security, would not be able to do it manually or via Gparted. That would make thing whole lot more complicated and messy. That would infact make this whole thread pointless.

All i said was maybe the ParrotOS Devs would consider increasing the default /boot/ in guided install to avoid a whole lot of issues that users like me experience in future. I cannot explain further in any simpler language. It looks like this thread is going in circles despite the whole point is clear. If someone was able to have an encrypted install manually, why would he/she use the guided installation.

@dmknght is spot on. Though I hear what you’re saying we’ll add it to our todo and take a look, probably a couple of weeks.

1 Like

500 or 600mb

apt autoremove actually cleans old kernels keeping only the latest 2 or 3 kernels

the guided setup provides less than 300mb automatically only if you use a very old parrot ISO on a very small storage pool

1 Like

EXACTLY. Thats the whole point of this thread that im trying to convey.

I think installed ParrotSec as 4.1 or 4.2 and it provided me with nearly 256mb.

This is what i was requesting to implement in this thread since I wasnt aware of it that 4.4 implements it as I installed Parrot 4.1 or 4.2, about an year ago.

which requires space. And limiting boot to less than 256mb to 300mb on disk that has 1024GB free space via guided install, gets bit (a lot) messy in later days.

Now that according to the devs, the default boot space is increased (assumably in guided install, too). I rest my case :slight_smile: