Dependency issues in Virtualbox

Afte installed parrot security 4.6 then i link the updating button after that i wanted to install the drivers of virtualbox, but i start to have a problem of installing Virtualbox-guest, Virtualbox-guest-x11.
Loading new virtualbox-guest-6.0.8 DKMS files…
Building for 5.1.0-parrot1-3t-amd64
Building initial module for 5.1.0-parrot1-3t-amd64
Error! Bad return status for module build on kernel: 5.1.0-parrot1-3t-amd64 (x86_64)
Consult /var/lib/dkms/virtualbox-guest/6.0.8/build/make.log for more information.
dpkg: error processing package virtualbox-guest-dkms (–configure):
installed virtualbox-guest-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of virtualbox-guest-utils:
virtualbox-guest-utils depends on virtualbox-guest-dkms (= 6.0.8-dfsg-4) | virtualbox-guest-source (= 6.0.8-dfsg-4) | virtualbox-guest-modules; however:
Package virtualbox-guest-dkms is not configured yet.
Package virtualbox-guest-source is not installed.
Package virtualbox-guest-modules is not installed.
Package virtualbox-guest-dkms which provides virtualbox-guest-modules is not configured yet.

dpkg: error processing package virtualbox-guest-utils (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
virtualbox-guest-dkms
virtualbox-guest-utils
Configuring sandbox profiles…
Sandbox profiles updated!
Scanning application launchers
Updating active launchers
Done
E: Sub-process /usr/bin/dpkg returned an error code (1)

I believe current version of vbox dkms is not compatible with our kernel version. We’ll update it as soon as possible.

But if i do not update it after i just installed the Parrot security it works nice, the virtualbox-guest-utils and virtualbox-guest-x11 installing without any error. Only after i upgraded it started error

Did you notice that our current kernel version is 5.1 and parrot 4.6 version after setup was 4.18 or 4.20?

Nothing like being on a pentest job and see updates, install and it breaks everything.

Any eta on a fix for this?

currently installing a new kali vm so i can finish my job ffs

We are very sorry about your problem. You see, Intel exploit, bluekeep and other vuln was a mess. Our project leader decided to upgrade kernel to 5.1, the latest because Debian patched slowly. Unfortunately, other companies do it slower and we are having other mess. We updated dkms packages for broadcom, … but it was not enough. I’ll as our team and feed back after few hours.

I remember few years ago when I installed Kali, I ran update and gnome3 did allow me to log in LoL. I totally understand your feeling. Again, very sorry about your problem (and other users problem include me ofc).

Yep I think i had that same issue with Kali and then soon after i found Parrot and i made the switch.

I get that issues come up and as Parrot is security focused, and having “some” protection from the intel mess is a priority.

Not sure if you are a dev or not but if so, thanks for making parrot in the first place. I recently passed my OSCP and used parrot the whole way, exam went great with parrot as well.

another question (sorry for not making a new topic) but:
did the issue with host file entries not being recognised get fixed? i did run into issues with that with parrot as well awhile back on a job, setting dns names didnt apply, but on Kali it did.

Cheers
-z3n

Congrat! I want to take OSCP as well but… nah I can’t train myself good enough. About our Parrot, basically we are having the same tool list as Kali and we included canutils. A little spoiler: We are dropping old out ot dated tools, adding new tools and I am patching some tools as well. This is a little slow because there are new devs just learned about Debian packaging in 1 or 2 months. (and ofc their job takes time). So, I can say Parrot can do everything Kali can do in pentesting process, but we will increase our distro power by adding new tools and other stuff

For my system, I have to close firefox and open it again to make firefox takes hosts config. Commands like ping, host worked fine for me. Can you create a new topic, please? Maybe we can track this problem better and fix it if it is a real issue.

Thanks, You should take the OSCP, well worth the experience (and aggravation :wink: )

When you have the vbox issue sorted, i will fire it up and try the hosts file again and see if it works, then i will create a new topic.

Thanks again

1 Like

Looks like combining this issue with another:


and got to the point where
cd /usr/src/linux-headers-5.1.0-parrot1-3t-common/include
ln -s drm/ttm
did the quick and dirty job.
Maybe someone like to propose a cleaner fix concerning include-calls in the header-files of the virtualbox-guest-dkms-package.

@teddy You rock! I’m not sure what this simlink did but its working now.

Thanks.

It’s a quick&dirty fix for a include gone wrong. Symlinks are normally no real solution since this one will be gone (or at least on the wrong folder) when the next kernel version arrives. For now, it give the include the folder it is looking for, which is actually a subfolder.

The file not found error queries for the folder ttm yet this is a subfolder of drm. So either the include call should change or the drm folder must be in the library paths or something similar I’m not aware of.

Since I’m no developer nor package maintainer, I prefer not meddling around in these files, especially since the packages replace them on every dpkg-config-call. Still, quick&dirty means that it says. :wink:

I think, the maintainer of the package virtualbox-guest-dkms needs to adapt the include to the new linux-headers, maybe even with a kernel version switch or something like that.

But maybe, they should just talk to each other and decide together. :slight_smile:

As a work around for anyone who really wants virtualbox you can always go on to the virtualbox website and download their 6.0.8 version, it will show up to the package manager as simply 6.0 so be carefully with any autoremoves but it works perfectly fine.