DNS leak with VPN

Briefly describe your issue below:
Hello First of all I would like to say that I am new with Parrot but I really love it, it is so great that I decided to use it as my main system. I have configuration on Virtual Box:
Whonix Gateway - Parrot Home(as Workstation)
In parrot I have installed NordVPN(with app, no openvpn, have changed protocol to TCP to work with tor).
Generally it is working but I have noticed that DNS do not change.
Wheather country I choose in nordvpn I have always Singapore DNS.
When I run extended dnsleaktest.com it is written:
Hostname: singapore1.sg.apac.parrotsec.org ISP: OVH

When runing VPN it should use VPN DNS but in my system it does not work. Can you advise me what should I do?
My goal is to be 100% anonymous. What should I do that DNS will change automaticaly with VPN? For example German IP = German DNS

What version of Parrot are you running?
Home, Mate 1.20.4

What method did you use to install Parrot?
Debian standard

Configured to multiboot with other systems?

Have you tried using an openvpn config? Have you tried using UDP? (dns uses UDP)

The nord config should change your dns, so it might be that the app you are using is miss-configured.

It sounds like a complex setup, maybe take away some layers and try just a VPN in parrot first.

Also VPN’s do not make you anonymous. Don’t rely on a no logs policy.

Thank you for reply. Tor doesn’t support UDP. This is reason why I have used TCP.
I run Whonix Gateway then start Parrot Home. Tor runs with Parrot but I would like to have VPN over Tor in Parrot
I choose Nordvpn because they have their app for linux distro, which has such options like killswitch.
I haven’t tried openvpn on Parrot.

I do not use openvpn because I do not manage to configure firewall properly to work as killswitch. I found that nordvpn app is working better

So i would guess, because you are using just TCP the VPN isnt handling your DNS. Therefore your system is just using the DNS server in /etc/resolv.conf, through the TOR DNS port. You could test this by changing the servers listed in resolv.conf.

Saying that, im not sure how you would dynamically change your DNS (if thats what you want).

Whonix have a few articles on tunneling:

Also debate on the security of tunneling:


Don’t use these kinds of vpn. You have to configure your proxychains.conf file to allow only dynamic proxychains. Also, you can use anonsurf along with it. If you have Parrot OS then why do you need these kinds of applications?

Thank you for your sugestion. I have changed DNS for NordVPN DNS in /etc/resolv.conf as you said and it helped so for now it is working
But I was curious about openvpn,I will try once again configure it with openvpn(First time I have failed with firewall)

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.