DNS resolution does not work out of the box

Briefly describe your issue below:

DNS resolution does not work out of the box

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Parrot-security-4.9.1_virtual.ova

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Import OVA file in VirtualBox (on Fedora 32) 6.1

Configured to multiboot with other systems? (yes / no)

no

List your networking hardware (make, model, firmware version):

On VirtualBox:

Slot:	00:03.0
Class:	Ethernet controller
Vendor:	Intel Corporation
Device:	82540EM Gigabit Ethernet Controller
SVendor:	Intel Corporation
SDevice:	PRO/1000 MT Desktop Adapter
Rev:	02
Driver:	e1000
Module:	e1000

On Physical machine:

Slot:   02:00.0
Class:  Network controller
Vendor: Intel Corporation
Device: Wireless 8260
SVendor:        Intel Corporation
SDevice:        Device 0110
Rev:    3a
Driver: iwlwifi
Module: iwlwifi

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

host www.linux.com
;; connection timed out; no servers could be reached

Details of the issue:

FIle /etc/resolv.conf:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 192.168.10.254
nameserver 192.168.10.1
nameserver 192.168.1.1
search lan

Well, I’ve found this, somewhat fun. I’ve came to Parrot OS searching a Distro interested in security, and there are hardcoded nameservers. Or am I missing something?

Why are those lines there?

Besides to this, If I run (either root or non-root user) systemd-resove --status as happily suggest that file, it outputs:

Failed to get global data: Unit dbus-org.freedesktop.resolve1.service not found.

If I run systemctl enable systemd-resolve:

/etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symbolic link to /run/resolvconf/resolv.conf

I can manage to edit by hand /etc/resolv.conf, but these behavior is somewhat curious

So I don’t understand, what method are you using to name resolution? Do you want that be manually, by sistemd-resolve, by resolvconf? Could you clarify?

Thanks in advance!
S.

It is a mistake of ova file. run sudo dnstool dynamic or sudo dnstool static opennic