Dual monitor not detected

Hi, I have recently installed Parrot Security MATE and I love the operating system apart from some of the small bugs, e.g that you have to change the resolv.conf file to get the internet working.

But today, when i tried to plug in my second display via HDMI it didn’t work, it doesn’t even detect any display, then I taught I might just have to install the nvidia-driver so I did but it didn’t fix anything. With the nvidia-driver it also comes with Nvidia X Server settings and I can’t even open that program to check if it finds any displays. If I run nvidia-settings in the terminal it gives this:

┌─[✗]─[willy@parrot]─[~]`
└──╼ $nvidia-settings
ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

But I was able to use it a couple of reinstalls ago(I have reinstalled Parrot about 10 times to try and fix this display issue) and then NVIDIA detected my other monitor. I guess I should also mention I have tried on Kali Linux too but the same problems occur there as on Parrot.

I also helped my friend install Parrot OS on his laptop(Lenovo Legion with some gtx gpu) and everything worked completely fine for him, he didn’t even have to install anything, we both used the same USB.

I think it has something to do with the graphics card or some drivers but I can’t seem to figure this out how much I research, please share if you have any ideas.

System specs:

*Laptop: MSI *
*OS: Parrot Security 4.1 MATE *
*CPU: Intel I5 10th gen *
*GPU: NVIDIA RTX 2060 6GB *
I would give the nvidia driver version but couldn’t figure out how to get it so.
I run parrot as a dual boot so my other os is windows 10 and the display works fine there.

1. Your Parrot information

    ```

DISTRIB_ID=Parrot
DISTRIB_RELEASE=4.10
DISTRIB_CODENAME=rolling
DISTRIB_DESCRIPTION=“Parrot 4.10”
PRETTY_NAME=“Parrot GNU/Linux 4.10”
NAME=“Parrot GNU/Linux”
ID=parrot
ID_LIKE=debian
VERSION=“4.10”
VERSION_ID=“4.10”
HOME_URL=“https://www.parrotsec.org/
SUPPORT_URL=“https://community.parrotsec.org/
BUG_REPORT_URL=“https://community.parrotsec.org/

    ```
    ```
    Linux parrot 5.9.0-2parrot1-amd64 #1 SMP Debian 5.9.6-2parrot1 (2020-11-17) x86_64 GNU/Linux
    ```

- Your device name or output of `lspci`
```
    00:00.0 Host bridge: Intel Corporation 10th Gen Core Processor Host Bridge/DRAM Registers (rev 02)

00:01.0 PCI bridge: Intel Corporation 6th-10th Gen Core Processor PCIe Controller (x16) (rev 02)
00:02.0 VGA compatible controller: Intel Corporation CometLake-H GT2 [UHD Graphics] (rev 05)
00:12.0 Signal processing controller: Intel Corporation Comet Lake PCH Thermal Controller
00:14.0 USB controller: Intel Corporation Comet Lake USB 3.1 xHCI Host Controller
00:14.2 RAM memory: Intel Corporation Comet Lake PCH Shared SRAM
00:14.3 Network controller: Intel Corporation Comet Lake PCH CNVi WiFi
00:15.0 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH Serial IO I2C Controller #0
00:15.2 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH Serial IO I2C Controller #2
00:16.0 Communication controller: Intel Corporation Comet Lake HECI Controller
00:1d.0 PCI bridge: Intel Corporation Comet Lake PCI Express Root Port #9 (rev f0)
00:1d.4 PCI bridge: Intel Corporation Device 06b4 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Comet Lake LPC Controller
00:1f.3 Audio device: Intel Corporation Comet Lake PCH cAVS
00:1f.4 SMBus: Intel Corporation Comet Lake PCH SMBus Controller
00:1f.5 Serial bus controller [0c80]: Intel Corporation Comet Lake PCH SPI Controller
01:00.0 VGA compatible controller: NVIDIA Corporation TU106M [GeForce RTX 2060 Mobile] (rev a1)
01:00.1 Audio device: NVIDIA Corporation TU106 High Definition Audio Controller (rev a1)
01:00.2 USB controller: NVIDIA Corporation TU106 USB 3.1 Host Controller (rev a1)
01:00.3 Serial bus controller [0c80]: NVIDIA Corporation TU106 USB Type-C UCSI Controller (rev a1)
02:00.0 Non-Volatile memory controller: Lite-On Technology Corporation Device 9100 (rev 03)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
```

Is your BIOS running Legacy mode by chance?

Is your bios on legacy mode?

And also what command did you use to get the NVIDIA drivers? If you used apt-get that’s where you went wrong.

Try going into synaptic package manager and see if you can find them there or go into display and configurations and see if something is going on in there.

Another thing you can try is restarting your computer and then plug the HDMI in