error de llaves publicas & sudo apt-get update

buen dia, alguien porfavor me ayuda con este erros. esto sucede al tratar de actulizar parrot os:

Des:1 http://deb.parrotsec.org/parrot stable InRelease
Err:1 http://deb.parrotsec.org/parrot stable InRelease
Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY B56FFA946EB1660A
Descargados 14,3 kB en 2s (6.093 B/s)
Leyendo lista de paquetes… Hecho
W: Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. Error de GPG: http://deb.parrotsec.org/parrot stable InRelease: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY B56FFA946EB1660A
W: Fallo al obtener http://deb.parrotsec.org/parrot/dists/stable/InRelease Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY B56FFA946EB1660A
W: No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar.

se que es un error de llaves por que esta desactualizado pero no se como solucionar, de antemano muchas gracias

Sigue What should my sources.list look like? Here.

Buenas tardes saludos al seguir las indicaciones del link me arroja lo siguiente

asegúrese de tener instalado “parrot-archive-keyring”, de lo contrario, instálelo
Screenshot at 2020-05-31 14-31-48

ya esta instalado en su versión mas reciente

Lo siento por responder tarde

Descargue e instale la versión más reciente “parrot-archive-keyring 2019.6+parrot2 all.deb

  1. puedes descargarlo desde este espejo : Here
  2. luego instale el paquete
  3. luego actualice su sistema usando sudo parrot-upgrade