Error processing:

linux-image-4.15.0-parrot17-amd64

—what happens is that every time I want to install something, either by package manager or terminal it throws me an error and it does not let me install, or uninstall.
-The error that generates me is:

/usr/sbin/grub-mkconfig: 34: /etc/default/grub: Syntax error: EOF in backquote substitution
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 2
dpkg: error al procesar el paquete linux-image-4.14.0-parrot13-amd64 (–remove):
_ installed linux-image-4.14.0-parrot13-amd64 package post-removal script subprocess returned error exit status 1_
Se encontraron errores al procesar:
_ linux-image-4.14.0-parrot13-amd64_
Configuring sandbox profiles…
Sandbox profiles updated!
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Tratando de recuperarlo:
dpkg: problemas de dependencias impiden la configuración de linux-image-amd64:
_ linux-image-amd64 depende de linux-image-4.15.0-parrot17-amd64; sin embargo:_
_ El paquete `linux-image-4.15.0-parrot17-amd64’ no está configurado todavía._

dpkg: error al procesar el paquete linux-image-amd64 (–configure):
_ problemas de dependencias - se deja sin configurar_
Se encontraron errores al procesar:
_ linux-image-amd64_

What version of Parrot are you running? (include version, edition, and architecture)

Versión 3.11 de 64 bits

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian standard

Configured to multiboot with other systems? (yes / no)
No

does it happen with parrot 4.0 or 4.1?

Parrot 3.11

please don’t use parrot 3.11