Ethernet rtl8169 r8169 no internet no dhcp

Briefly describe your issue below:
(irc chat log that describes it so i don’t have to retype)
hi
from what i know rtl 8169 is in the linux like built in so you don’t have to worry aobut the network
for the past 10 linux installs i think i had no problem
today i installed parrot again to see stuff that changed and i have no network on ethernet and i’ve tried like all the solutions under the sun
i faced the same problem in the past and i fixed it by just running dhclient enp4s0 and it worked but now it seems like it’s not working
any ideas?

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Linux parrot 5.5.0-1parrot1-amd64 #1 SMP Parrot 5.5.17-1parrot1 (2020-04-25) x86_64 GNU/Linux i think it’s kde if that’s the default, or xfce doesn’t matter

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
the standard

Configured to multiboot with other systems? (yes / no)
nope

List your networking hardware (make, model, firmware version):
rtl 8169 which is built in as my problem description states

If there are any similar issues or solutions, link to them below:
i looked on every single search result on the first page of google of people with similar problems and i think i’ve tried almost everthing
https://pastebin.com/kmL9SJr6 this is just 50% of the stuff i tested, i like opened a new terminal and it aparently didnt saved so

If there are any error messages or relevant logs, post them below:
└──╼ $lspci | grep net
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

and some other thing

Listening on LPF/eth0/b4:2e:99:92:41:18
Sending on LPF/eth0/b4:2e:99:92:41:18
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

I see history list of commands on your pastebin, but no returned output from entering them.

EDIT: disregard previous type up trying to learn more about your problem.

Your question is poorly formed and leaves out details. Repeating the driver names over and over in reference to internet problems, at first glance, gives appearance you may have thought there was a problem with it. Anyhow I don’t have time to help rude people. Good luck.

What leads you to believe it is this? this is just a dumb question, it was a fresh parrot install and it didn’t worked, which is no surprise since debian needs special treatment everytime there’s a problem compared to ubuntu.

Do you have any errors related directly to this driver leading you to believe it is faulty? another dumb question since the driver is built in the linux kernel

Have you tried reinstalling the driver? yes

Did Parrot Live mode internet work? no

such a stupid community that they can’t even offer support to an ALREADY supported internet driver in the liunx kernel, what a bunch of autists lol