Failed to Configure Package Manager

Briefly describe your issue below:
While attempting to install Parrot OS, it fails at the installation step for configuring the package manager. I’m installing with a USB formatted by Rufus in DD mode as recommended by one of the error screens I received in a previous attempt. I’ve tried installing it both from the live environment as well as going directly into the installation. I’ve verified the checksum of the .iso file I downloaded from one of the official mirrors and I’ve attempted the installation a few times already. The rest of the installation goes through fine, but then I’m left with not being able to update or install any packages. I attempted to fix it by grabbing the parrot-updater.deb file from http://deb.parrotsec.org, but that didn’t change anything because it seems to find that package as already installed on the machine. I’m fairly new to linux, so bear with me if I’m sounding like a total newbie.


What version of Parrot are you running? (include version, edition, and architecture) Parrot Security 4.5.1 amd64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental) Debian Standard

Configured to multiboot with other systems? (yes / no) No

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

Please install via the official method:
https://www.parrotsec.org/docs/getting-started/create-boot-device/

To update, execute the following from terminal (default Alt+T)

sudo parrot-upgrade

I just used etcher with a checksum-verified .iso and I got the same result: failed to configure package manager. However, I ran sudo parrot-upgrade after the installation and had that process run. I tried sudo apt-get update to see how it behaved, and it only checked for the CD source. I had to go into Synaptic Package Manager and deselect the CD as a repository and now it seems to be acting normally by reaching out to http://deb.parrotsec.org/parrot. I was able to successfully install Tilix, so I assume it is functioning now. Is there anything else I should check to verify package manager is working properly?

Interesting error, can you give more details on everything you did up to that point? Was your system connected to the internet?

Avoid using apt-get use apt (apt-get is not really needed for updating, when in doubt use apt you will avoid a lot of headache)

apt is your package manager. If

sudo parrot-upgrade

ran with no errors (and it should) then everything is configured correctly. For further information see:

man apt

man (manpages) is your friend to learn about unix and linux systems. man isn’t the perfect learning method but it gives you a solid starting point, for more help check out the little helpme we wrote. You can also install info by the GNU project which is super useful.

Through the multiple times of attempting the installation, I tried both while connected to the Internet and not connected. IIRC, I did not have it connected during the latest installation because I had read on a few posts that having it connected would at times cause conflicts in the setup. As far as everything else that I did up to that point, I can’t think of anything worth noting besides that I used the Standard Debian installer once again instead of the GTK installer. I had tried in previous attempts to use GTK, but abandoned it once it seemed that I was safer going with the standard.

Thanks for the tip on apt-get vs. apt. As far as I can tell, sudo parrot-upgrade completed successfully without any errors. I’ll also look into that helpme that you linked.

1 Like

yeah you’ll get that error if you aren’t connected but its not an issue.

Hey I need a little help here…
Which repository did you remove exactly?
I am unable to locate the repository. Could you please provide the steps?

I’ll have to look it up later if it’s still there, but I found it in the GUI for Synaptic Package Manager.

i was having the same trouble for days just read your post and WOW its fixed just wanted to say a big thank you :slight_smile: now i can love parrot again lol

Hey @ebpx

I am facing the same problem. I dont know what to do either. Can you tell me how you solved your packet manager problem. I searched in internet but couldn’t find an accurate solution.I really need help with that.