Failed to copy file from installation media. Retry ?

I am trying to install parrot in my compute which have Manjaro(still running) & i am not sure if it’s on UEFI or BIOS mode, maybe it’s on UEFI because i am not seeing grub.

My problem is that whenever i try to install via gtk installer i get the message “failed to copy file from installation media. Retry ?”

*I cant boot into live mode
*Cant load in to ram
*Basically stuck into live menu
*No problem with USB(because installed Manjaro with the same USB)
*Also not an ISO problem (tried home & security both)

BIOS : GIGABYTE - UEFI BIOS( H81M-S )

what did you use to burn Parrot? Be sure to use only Etcher or dd or you may run into problems like this.

I used dd command

did you remember to sync after using dd ?

after your comment i tried this but not working
the command i used
sudo dd oflag=sync status=progress if=Parrot-security-4.9.1_x64.iso of=/dev/sdc

1 Like

I moved from Manjaro a few weeks ago. I was never able to run Parrot from a live medium with Manjaro installed as my Primary.
Did a complete install of Parrot, overwriting Manjaro and all good, However, couldnt then do a dual boot reinstall of Manjaro as Parrot no longer recognized.
Solution: Installed Manjaro on Virtualbox and all well. Mind you after using Parrot for a while ditched Manjaro and now dont even miss it.
bing

1 Like

@bing
It is very true what you say about the Parrot grub.
I have 2 disks in my pc, in the first disk I have Parrot 4.9 and in the second I have EndeavorOS, this last one takes Parrot in his grub and I can start both distros without problems, now well; with the Parrot grub I cannot start Endeavor only Parrot and if I choose to start Endeavor it throws a Panic kernel.

I always use imagewriter and I never had problems, for that reason I write this and with all respect towards you, in my experience, everything depends on the hardware that each one has, some work as they should and others not so much, despite of from an established standard.

1 Like

I will say, use whatever works for you. Many potential programs burn a copy nicely.

We stick to suggesting dd/Etcher as is suggested in Parrot Wiki “Create Boot Device” guide:
https://docs.parrotsec.org/getting-started/create-boot-device/

Others like unetbootin have been known to lead to issues.

Keeping it simple and sticking to the Wiki here helps prevents flooding of forum w/unnecessary questions :grin:

2 Likes

[SOLVED]

there was a problem in download, i dont know if it was serverside or my side but i downloaded from “Direct download” option which somehow only downloads 500MB iso whic was strange when i checked signatures and they didn’t match so i downloaded from torrent and its now working.

2 Likes