Failed to fetch deb.parrotsec.org

I cant update. If write command apt-get update, it shows that Failed to fetch http://deb.parrotsec.org/parrot/pool/main/s/scrot/scrot_0.8-19_amd64.deb Cannot initiate the connection to deb.parrotsec.org:80 (2401:c080:1000:4867:5400:1ff:fedb:6539). - connect (101: Network is unreachable). I cant understand anything even its my first time install linux.
I have downloaded parrot security from parrotsec.org
My parrot version is mate(latest version).


What version of Parrot are you running? (Parrot Mate1.20.4 kernel linux 4.19.0)

What method did you use to install Parrot? (Debian Standard)

Configured to multiboot with other systems? ( no)

**If there are any similar issues or solutions, link to them below:**no

**If there are any error messages or relevant logs, post them below:**no

2 Likes

Same here?

Just Wait
I think @palinuro repairing CDN

Try using a mirror near your to you, that should have the latest release, assuming whatever problem exists in the CDN isn’t fixed by now…

1 Like

Okay i will try
Thank you

Thanks. It worked.

hi can someone help me with this error please.

Failed to fetch http://deb.parrotsec.org/parrot/dists/parrot/InRelease Something wicked happened resolving ‘deb.parrotsec.org:http’ (-5 - No address associated with hostname)…and in syn package manager i get this message to…he repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.

go to sources.list and change the mirror

ok ty but how to find available mirror and lists,i used parrot-mirror-selector but its old tool,where to find that mirror list and how to change it?ty

You can get lots of mirror in this link
https://www.parrotsec.org/docs/mirror-list/

1 Like

This issue happens because previous apt version fixed RCE vuln (my opinion). Upgrade apt to latest version will fix it (it is harder when you can’t connect to parrot repository using apt command LoL). You can read it here https://community.parrotsec.org/t/update-parrot-being-blocked/5775

I tried everything in a couple of posts on this, and all the apt’s at the mirror I tried said they not be installed as they would break the system. I then tried re-installing 4.5 and it could not configure the apt-manager. I ended up re-installing but not updating 4.3. I am not much of an expert on Linux, but I like Parrot for privacy and security. Yet I find apt having a bug completely unacceptable. Does anyone know when this bug will be fixed? If these kind of mistakes keep happening I will have to reconsider using Parrot, as I don’t really have the skills to fix this kind of thing and probably never will.

I reformatted and attempted to update 10 time. Finally gave up. I’m using 4.4 4.18.0-parrot10-amd64 until something comes up I can do.

1 Like

I agree. Not everyone is a Linux geek. Linux is suppose to be for everyone now. Yet we have a bug in apt? I have used Linux for 4 or 5 years now, and fixed plenty of problems, but some should just not happen. Where was the notice of this? Why did we have to come to the forum to find this out? I can fix a lot of things, but not a broken package manager. When will the problem be fixed? I am willing to give it ONE MORE TRY if I can find out something, but not if the developers don’t care.

1 Like

I understand and appreciate Linux is free. I also stated it is my limited ability. I am older and have trouble with some simple things like installing a tar ball. I use a GUI for most everything. I really like Parrot, and would like to continue to use it. Yes some of the advice here might not have been totally accurate, but it is all I have to rely on. I will hang in there until the next point release.

2 Likes

I see a lot of the same errors I have on my system showing up in other peoples systems after the 4.5 upade. dmknight says that installing the upgraded apt manually will probably fix the problem in amd64. I had 12 tabs open in the debian manual yesterday to try to figure this process out. The only thing I did find, are several commands that we are told on this forum not to use. Commands to fix recommended commands, in case of a problem. Over and over and over again, took me to hours 2 to figure out that I wasn’t going to be able to do it. In the last 2 weeks I have probably spent 50 hours researching and reformatting this computer, in an attempt to make 4.5.1 even remotely useable. If the apt is broken, for me, its going to stay broken until its fixed in the iso. My problem. I don’t expect any one here owes me anything, certainly not the ones doing all the work to make it possible. I would do more if i could, but I can’t. What I see a lot of, from you, is, when someone posts a problem, your first response is generally something like “what did you do”. You make accusations as if someone sabotaged their own system, just to make things harder for you. And I am looking at the same logs on my computer, immediately after installing the iso. Most of us are never going to operate at the same level as you. Some of us could have 30 years ago, but those days are gone. I guess what I am saying, is if you want to help, help. If you don’t, then don’t reply. Displaying your superior skill, and looking down on people who don’t possess them, is counter-productive. If anyone thinks this is out of line, feel free to delete it. If anyone doesn’t want a 60 year old, who’s intellectual prime has passed, you may feel free to delete my account.

2 Likes

Just clear the air. Parrot is Debian based, so there are bugs from Debian and affected Debian distro as well. About that fetch Domain name error: First time I read that news, and I upgraded apt after 2 days, I thought that bug was because of the fix. But this issue still happens (rarely) for me so I am thinking about DNS error.
No offensive here, but Parrot is not made for regular users. And because it is based Debian testing so there would be many bugs / errors that any user can have. If anyone wants a stable Parrot, yes there would be LTS version. I think LTS version will be easier to use for new users and have less bug.
p/s: I am really sorry about your apt broken. That was my fault because I didn’t make a clear solution.

1 Like

For me, I tried it on different internet connection of different ISPs but still the error persists. I am using Parrot Security and I cannot afford to reinstall it again as I have a lot of data in it. Please help!!

For now I have removed Parrot. I will try re-installing it on the next point release. I am using Siduction right now, and have had no real problems. Using Siduction for now is giving me some much needed experience with a rolling distro. I really want to use Parrot, so waiting patiently for the next point release. Hopefully things will go better.

1 Like

This post worked for me, my issue was with my DNS. Thanks my brother

1 Like