Failed to load module "mouse" erorr

(Matt) #1

Briefly describe your issue below:
I went ahead and tried a fresh install. First and only thing I did was do the normal updates it asks for. Once the updates complete, the only way to boot without crash is the acpi off option. Thats not a problem.

My problem is I cant get parrot to detect my GPU. I went back to windows breifly to just test and see if my GPU was bad but everything checked out. I go through everything mentioned here step by step word for word.

When I try to run anything optirun it gives me this error.

[11913.085050] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module “mouse” (module does not exist, 0)

[11913.085067] [ERROR]Aborting because fallback start is disabled.

I have been on this for about a week and just cant figure it out. I understand linux and nvidia are not best friends but id like to make them at least socialize on parrot. If theres anything else I can provide to help with let me know.

What version of Parrot are you running? (include version, edition, and architecture)
Linux parrot 4.19.0-parrot1-20t-amd64 #1 SMP Parrot 4.19.20-2parrot1.20t (2019-03-09) x86_64 GNU/Linux
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Standard
Configured to multiboot with other systems? (yes / no)
No
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

(vladislav) #2

Firsty, please don’t make your topic name “i give up”, “i don’t know what’s the error”. Name it the problem you facing.

Try running

sudo apt install xserver-xorg-input-mouse
2 Likes
(Matt) #3

Good point. I did run this and insall it and now instead of a mouse error this is what I get with any optirun command.

[ 109.770348] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:2:0:0. Please

[ 109.770372] [ERROR]Aborting because fallback start is disabled.

I went ahead and tried to boot with the default option without acpi=off
I still cant optirun anything via sudo or normal user. This is the error it gives me with the default grub boot config.

[ 166.267515] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 166.267599] [ERROR]Aborting because fallback start is disabled.

(vladislav) #4

Try running optirun with -vvv option and open

journalctl -f | grep bumblebeed

in another terminal and try to run optirun again. If errors occur, post content of journalctl.

(Matt) #5

Apr 07 14:10:28 parrot bumblebeed[1131]: [ 5492.425119] [ERROR][XORG] (EE) No devices detected.
Apr 07 14:10:28 parrot bumblebeed[1131]: [ 5492.425135] [ERROR][XORG] (EE)
Apr 07 14:10:28 parrot bumblebeed[1131]: [ 5492.425138] [ERROR][XORG] (EE) no screens found(EE)
Apr 07 14:10:28 parrot bumblebeed[1131]: [ 5492.425141] [ERROR][XORG] (EE)
Apr 07 14:10:28 parrot bumblebeed[1131]: [ 5492.425146] [ERROR][XORG] (EE) Please also check the log file at “/var/log/Xorg.8.log” for additional information.
Apr 07 14:10:28 parrot bumblebeed[1131]: [ 5492.425149] [ERROR][XORG] (EE)
Apr 07 14:10:28 parrot bumblebeed[1131]: [ 5492.425152] [ERROR][XORG] (EE) Server terminated with error (1). Closing log file.
Apr 07 14:10:28 parrot bumblebeed[1131]: [ 5492.425155] [ERROR]X did not start properly
Apr 07 14:11:07 parrot bumblebeed[1131]: [ 5531.247307] [ERROR][XORG] (EE) No devices detected.
Apr 07 14:11:07 parrot bumblebeed[1131]: [ 5531.247323] [ERROR][XORG] (EE)
Apr 07 14:11:07 parrot bumblebeed[1131]: [ 5531.247327] [ERROR][XORG] (EE) no screens found(EE)
Apr 07 14:11:07 parrot bumblebeed[1131]: [ 5531.247331] [ERROR][XORG] (EE)
Apr 07 14:11:07 parrot bumblebeed[1131]: [ 5531.247337] [ERROR][XORG] (EE) Please also check the log file at “/var/log/Xorg.8.log” for additional information.
Apr 07 14:11:07 parrot bumblebeed[1131]: [ 5531.247340] [ERROR][XORG] (EE)
Apr 07 14:11:07 parrot bumblebeed[1131]: [ 5531.247344] [ERROR][XORG] (EE) Server terminated with error (1). Closing log file.
Apr 07 14:11:07 parrot bumblebeed[1131]: [ 5531.247347] [ERROR]X did not start properly

(vladislav) #6

Please follow this Tuto install of bumblebee and drivers and this Tuto install of bumblebee and drivers instructions.

(Matt) #7

All of that is already installed as mentioned in OP. Every step mentioned in both of those discussions and also here

I’m just very confused. A fresh install with updates and every step followed in those discussions and the parrot docs and I can’t get it to work. lspci detects my nvidia gpu. Ive tried with both the acpi on and off options.

(vladislav) #8

Also give me the output of /var/log/Xorg.8.log file.

(Matt) #9

GNU nano 3.2 /var/log/Xorg.8.log
[ 17261.917]
X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
[ 17261.917] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[ 17261.917] Current Operating System: Linux parrot 4.19.0-parrot1-20t-amd64 #1 SMP Parrot 4.19.20-2parrot1.20t (2019-03-09) x86_64
[ 17261.917] Kernel command line: BOOT_IMAGE=/vmlinuz-4.19.0-parrot1-20t-amd64 root=/dev/mapper/parrot–vg-root ro quiet splash noautomount quiet
[ 17261.917] Build Date: 25 October 2018 06:15:23PM
[ 17261.917] xorg-server 2:1.20.3-1 (https://www.debian.org/support)
[ 17261.917] Current version of pixman: 0.36.0
[ 17261.917] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 17261.917] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 17261.917] (==) Log file: “/var/log/Xorg.8.log”, Time: Sun Apr 7 17:26:37 2019
[ 17261.917] (++) Using config file: “/etc/bumblebee/xorg.conf.nvidia”
[ 17261.917] (++) Using config directory: “/etc/bumblebee/xorg.conf.d”
[ 17261.917] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 17261.918] (==) ServerLayout “Layout0”
[ 17261.918] (
) |–>Screen “Default Screen” (0)
[ 17261.918] () | |–>Monitor “”
[ 17261.918] (
) | |–>Device “DiscreteNvidia”
[ 17261.918] () | |–>GPUDevice “DiscreteNvidia”
[ 17261.918] (==) No monitor specified for screen “Default Screen”.
Using a default monitor configuration.
[ 17261.918] (
) Option “AutoAddDevices” “false”
[ 17261.918] () Option “AutoAddGPU” “false”
[ 17261.918] (
) Not automatically adding devices
[ 17261.918] (==) Automatically enabling devices
[ 17261.918] (**) Not automatically adding GPU devices
[ 17261.918] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 17261.918] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
[ 17261.918] Entry deleted from font path.
[ 17261.918] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 17261.918] (++) ModulePath set to “/usr/lib/nvidia/nvidia,/usr/lib/xorg/modules”
[ 17261.918] (==) |–>Input Device “”
[ 17261.918] (==) |–>Input Device “”
[ 17261.918] (==) The core pointer device wasn’t specified explicitly in the layout.
Using the default mouse configuration.
[ 17261.918] (==) The core keyboard device wasn’t specified explicitly in the layout.
Using the default keyboard configuration.
[ 17261.918] (II) Loader magic: 0x5590a7449e20
[ 17261.918] (II) Module ABI versions:
[ 17261.918] X.Org ANSI C Emulation: 0.4
[ 17261.918] X.Org Video Driver: 24.0
[ 17261.918] X.Org XInput driver : 24.1
[ 17261.918] X.Org Server Extension : 10.0
[ 17261.919] (–) using VT number 7

[ 17261.919] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 17261.919] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 17261.919] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[ 17261.921] (–) PCI:*(2@0:0:0) 10de:139b:1028:0706 rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x???/524288
[ 17261.921] (II) LoadModule: “glx”
[ 17261.922] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 17261.927] (II) Module glx: vendor=“X.Org Foundation”
[ 17261.927] compiled for 1.20.3, module version = 1.0.0
[ 17261.927] ABI class: X.Org Server Extension, version 10.0
[ 17261.927] (II) LoadModule: “nvidia”
[ 17261.927] (II) Loading /usr/lib/nvidia/nvidia/nvidia_drv.so
[ 17261.927] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 17261.927] compiled for 4.0.2, module version = 1.0.0
[ 17261.927] Module class: X.Org Video Driver
[ 17261.927] (II) LoadModule: “mouse”
[ 17261.928] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[ 17261.928] (II) Module mouse: vendor=“X.Org Foundation”
[ 17261.928] compiled for 1.20.0, module version = 1.9.3
[ 17261.928] Module class: X.Org XInput Driver
[ 17261.928] ABI class: X.Org XInput driver, version 24.1
[ 17261.928] (II) LoadModule: “kbd”
[ 17261.928] (WW) Warning, couldn’t open module kbd
[ 17261.928] (EE) Failed to load module “kbd” (module does not exist, 0)
[ 17261.928] (II) NVIDIA dlloader X Driver 410.104 Tue Feb 5 23:05:20 CST 2019
[ 17261.928] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 17261.928] (EE) No devices detected.
[ 17261.928] (EE)
Fatal server error:
[ 17261.928] (EE) no screens found(EE)
[ 17261.928] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 17261.928] (EE) Please also check the log file at “/var/log/Xorg.8.log” for additional information.
[ 17261.928] (EE)
[ 17261.928] (EE) Server terminated with error (1). Closing log file.

(Matt) #10

My log says not auto enabling the GPU. Is that my issue?

(Matt) #11

Ok my problem is solved I believe. Going to do some testing shortly to see. You need to edit the /etc/bumblebee/xorg.conf.nvidia (or /etc/bumblebee/xorg.conf.nouveau if using the noveau driver) and specify the correct BusID by following the instructions therein.

I used lspci to determine what my Nvidia card was listed under which was 02:00:0

Section “Device”
Identifier “DiscreteNvidia”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BusID “PCI:2:0:0”

That is all I changed in my xorg.conf.nvidia file. I just added the last line below Vendor Name.
I rebooted the machine and now I can optirun anything.

(vladislav) #12

Gratz! Look like Xorg had some problems with autodetecting your NVIDIA card, that’s why specifying BusID solved the issue.

1 Like
(Matt) #13

Thanks for your help. Everything is still running smooth. And for the record this is also using the default grub config without the acpi option.

(vladislav) closed #14