Failed to start light display manager?

You need to press ctrl + alt + F2 then type systemctl enable lightdm.service and Also start the service

1 Like

Actually, this doesn’t work for me. I get a long explanation after trying to enable lightdm. It says “unit files have no installation config… this means they are not meant to be enabled using systemctl.”
It talks about symlinks, dependencies, sockets, etc.

Any ideas? I just did an update, rebooted and this is what I get…

Here the same, os installed with gtk (dual boot w8.1), then sudo apt update && sudo apt dist-upgrade.
back in time i had installed nvidia driver by following the hashcat guidelines (they always worked for me so why change it, right?) and worked until the last update.
I tried a fresh install ( with and w/out gtk, ver 3.11 and 4.0 beta) but seems that every time I try to install the nvidia drivers, it fails.
without nvidia driver the desktop interface become buggy (parts of the gui flashing in red)
amd 8350
16gb ram
nvidia 970
evo 860 256 (entire for parrot)
500gb wd black (win8.1)
500gb wd blue (ntfs)
1tb wd red (ntfs)
1tb wd gold (500/500 ntfs/ext4)

just installed nvidia-driver nvidia-opencl-icd and so far so good… but i’m not sure they are working as they should, but at least the red flashy things are no more

hii i update to latest upgrade parrot 4.0
after i reboot it show failed to start login display manager see systematicl status light dm.service for details . how i get my gui system please help after that i use ctrl +alt+f2 i can only use by command please help to fix i want gui what i doo

I got the same result.

Here is a way, how to solve the problem with the VirtualBox

  1. When you obtain the failure message about lightdm, simply press ALT+F1 and log in there. then:
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install build-essential module-assistant
    sudo m-a prepare

  2. Insert Guest Additions ISO
    mount /media/cdrom
    sudo sh /media/cdrom/

  3. reboot


By the enteexsoftPavel way, it’s does work for me. thanks.

Confirmed working.
Thanks enteexsoft Pavel.

found great!!! thank you

hello enteexsoftPavel so whenever i impute this command mount /media/cdrom in virtualbox on the parrot os 4.0.1 LTS

i get the following – mount: media/cdrom0 : no medium found on /dev/sr0.

any support would be greatly appreciated :slight_smile:

In VirtualBox Parrot ‘Settings’ add the guest additions iso in ‘Storage’ as an optical drive.

If someone could please assist me with this issue. All I could launch is grub terminal. When I choose recovery or parrot OS. It is a blankscreen. I think I might have to reinstall the OS and all my work to solve this issue. I hate to do this!

hello there can you please help me here.i have the same problem except i boot it direct into my hdd and there is no vmware and virtualbox.

Hey what @enteexsoft posted is correct but between step 1 and 2 i could do this. At your VirtualBox virtualmachine that you just created choose the devices menu and click on the last option which says something like install Guest Additions ISO, then restart your virtual machine and when you have it running again proceed to step 2 by opening a terminal, reboot and when you do that you will see “magic”.

How? (This is the first time I’m trying to install Parrot)

Virtualbox. (Ubuntu 18.04 host)

The problem in gone but still stuck in boot. Nothing happens after

[ok] Started Light Display Manager.

Same result!

it worked for me thats

Hey guys! I’ve been having this problem for days now. I freshly installed the latest 4.x version of Parrot Sec OS and have the latest virtual box version. I tried so many things and i just figured it out while i was on the bus, so here goes:

All i did was fresh install with GTK (the more graphical install UI) - but i believe it won’t matter which you do. Then all i did was follow enteexsoft’s last command - sudo sh /media/cdrom/ - then command line “reboot”

Works like an angel sent from heaven :slight_smile: