Failed to start nameserver on port 53

parrot

(adeyemo stephen) #1

I was able to succresfully install evilginx on my parrotsec, but each time i start the evilginx i get the below error: “Failed to start nameserver on port 53” and i still cant find on service listning to that port.


(Lorenzo "Palinuro" Faletra) #2

the port is probably already taken by another service

find it and stop it, then retry


(adeyemo stephen) #3

thats the problem, i cant find it


(Nico Paul) #4

what command are you using to see whats using that port?


(Lorenzo "Palinuro" Faletra) #5

use this command to spot the process:

sudo netstat -ptnl | grep 53

(adeyemo stephen) #6

its not returning anything


(Nico Paul) #7

Tcp or udp? Try

netstat -a


(Lorenzo "Palinuro" Faletra) #8

sorry

netstat -putnl

give us the output


(adeyemo stephen) #9

(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:9050 0.0.0.0:* LISTEN -
udp 0 0 0.0.0.0:68 0.0.0.0:* -
udp 0 0 0.0.0.0:5353 0.0.0.0:* 4868/chrome
udp 0 0 0.0.0.0:5353 0.0.0.0:* 4868/chrome
udp6 0 0 :::5353 :::* 4868/chrome


(Nico Paul) #10

do you have a proxy set up on chrome? it looks like its going to localhost/loopback, there should be a setting within chrome (i advise firefox instead and its better easier and safer but not necessarily supported browserapp wise (ie unifi device discovery is only on chrome)) to open a task manager and kill those apps and go into settings and set them to also kill on chrome exit


(Lorenzo "Palinuro" Faletra) #11

try to run it as root


(adeyemo stephen) #12

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:9050 0.0.0.0:* LISTEN 750/tor
udp 0 0 0.0.0.0:49072 0.0.0.0:* 14009/openvpn
udp 0 0 0.0.0.0:68 0.0.0.0:* 26883/dhclient
udp 0 0 0.0.0.0:5353 0.0.0.0:* 1649/chrome
udp 0 0 0.0.0.0:5353 0.0.0.0:* 1649/chrome
udp6 0 0 :::5353 :::* 1649/chrome


(Nico Paul) #13

try

sudo kill pid 1649

then try what you wanted to configure


(adeyemo stephen) #14

Thanks, guys for your assistance, its now working :grinning:


(Nico Paul) closed #15

This topic was automatically closed after 26 hours. New replies are no longer allowed.