Failing To Install ParrotSec OS

Briefly describe your issue below:

What version of Parrot are you running? (include version, edition, and architecture)
4.5.1 ; Security Edition ; x86-64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debain Standard

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:
Something noteworthy: On the first attempt installing ParrotSec (4.5) was successful, however with only 5.7GB physical memory led me to boot into Live USB to add swap space (partitioning). I noticed that I partitioned the wrong side in GParted, fixed it, then return to installed system. I returned a few minor bugs however in attempts to repair I found myself stuck and decided to reinstall the system (with encryption this time, and to add Backup Manager). Installation afterwards failed without success.

I tried partitioning differently, the exact same, checking ISO Hashes, reinstalling iso (2 different USB drives) and other methods, I'm at a loss.

Also, would forcing UEFI installation help? (I discorvered this after formatting all partitions)

If there are any error messages or relevant logs, post them below:
The following is the same consistent error: An installation step failed. You can try to run the failing item again from menu, or skip it and choose something else. The failing step is: Configure the package manager

Skipping led to the same error

It would help to know more about which step failed…

How did you created Bootable USB
Create via etcher

why the i386 arch vs amd64? clean format with live disk and exit followed by booting to installer is def needed along with changing your bios settings completely

I did use etcher; following requirements by the home website.

I do not understand :confused:

The step after setting up partitions when the live USB installer is writing to the physical hard drive. When the installation is almost complete I receive the error (refer to image above)

Setting up the partitions manually can be tricky in the installer. Have you thought about using the lvm-crypt tools to shrink your /allinone partition by the swap space , swapon this partition and manually add ist in fsatb ? I have never tried that so you better ask someone who sucessfully done it.
Additionally you could compile yourself a 4.20 Kernel source because ist should support btrfs swapfiles.

this is a wonderful way to really mess it up further. you need to clean format with a livedisc and then reinstall in a separate instance (you should know what I mean here). do not edit fstab for at least another year. you do not need swap at all (no partition) when using btrfs vs ext2/ext3/ext4. you should really only use btrfs unless you really need ext2/3/4 for a weirdly specific reason. you need to probably be using the amd64 version instead of i386. (you definitely will in the next release and every one after). prior to all of these things however you need to change whatever needs changing in your BIOS settings to allow booting and installing alternative OS. secure boot off and allow bootable USB media.

1 Like

This is the specific solution: Do not use ext format use btrfs

I need Swap because my laptop has 5.7Gb or 8Gb pysical RAM (if that’s what you also ment)

EDIT: I also used GTK Installer on the successful run

Well 1st off those are very different numbers but no you dont. Whos telling you that you do?

None; when I update the OS it freezed then crashed 2 days ago (before this soft brick) by what I believe to be low RAM during update.

Swap makes things smoother when resources are being consumed by heavy task :wink:
hint hint click the wink

Only with ext dude. Btrfs literally is anti ram. Random data would ruin it because it doesnt make sense. Thus. No swap. No swap partitions no swap file. If you have 8g ram your lagging system was not caused by lack of swap or anything memory related save possibly some driver you needed due to hardware oddities.

1 Like

Have your problem been solved? I encountered a similar problem during installation from live view. What I did may not be the recommended solution though, but I simply ignored it and continued on the next step of the installation. Afterwards, everything turned out ok except when you run apt update after installing a package. Then I got an error saying something like I had to configure the apt package from something like cd rom… to the actual parrot package mirror-list. Sorry I can’t remember the exact words used. I simply removed everything in the " /etc/apt/sources.list" and allowed parrot’s default configuration located in " /etc/apt/sources.list.d/parrot.list." to take it’s course. That solved the problem.

Did you install the iso to USB using etcher? Etcher is the correct tool.

On my Dell e6330, I cannot install from live. Grub failure every time. I have to start from first start menu, then install using gtk installer. And even then, I have to watch carefully, because. it will try to install part of the partition on the live usb I am using. I think the package manager is one of the things it tries to put on the live usb. It always works better If I have a blank hard drive when I start.

1 Like

Its been a while, I’d have to run it again to be word for word specific, but its just along the lines of “grub installation failed, cannot install grub to partition xxxxx”. I’ve tried going back, trying something different, but eventually only manual is left. I’ve tried manual partitioning a couple of times, but I still lack the skills to do it. It does get confusing also because it seems to think of the usb installation media as part of the hard drive sometimes.