Faradaysec - Defautl Username/Password


(Vince W) #1

Briefly describe your issue below:

Can’t login to the faraday-ide portal.
Is there a default username/password or the username/password is generated in a file somewhere?

Thank you for your help! :slight_smile:


What version of Parrot are you running? (include version, edition, and architecture)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:


(Nico Paul) #2

What’s the output when you are halted?


(Matt) #3

https://github.com/infobyte/faraday/wiki/Install-steps-for-Faraday-v3.0

That used to be the link but looks like the page doesnt exist or has been moved. You needed to add the password to the database, before you could log in. They have an install section on their wiki try looking through that, it should provide the answer.


(Vince W) #4

Halted? Who talked about being stuck? I just can’t login to the portal. The server runs, the client connects to the server, then the web ui asks for a password. The F. is that password?!


(Vince W) #5

I was hoping to get farada-sec working easily with Parrot, but that’s not the case :frowning:


(Matt) #6

It will be the same for any new installation of faraday.

Follow the instructions: https://github.com/infobyte/faraday/wiki/Installation-Community
Its says in there, if you still cant log in, change the details in the database. See how to do that here: https://github.com/infobyte/faraday/wiki/Troubleshooting#cant-login-after-importing-from-couch


#8

@vwhissell at LEAST TRY to fill out the standard bug form before you post an issue. Here is a template:


What version of Parrot are you running? (include version, edition, and architecture)

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:


(Lorenzo "Palinuro" Faletra) #9

when you launch the faraday server, a new random password is generated and printed to the cli output


(dmknght) #10


Faraday login issue is already answered in this topic before
However my faraday has 500 error. I didn’t test with later version.
p/s: I tried to make an easy script to include output to faraday without using Faraday interface (which isn’t as good as terminal) but faraday team made it hard)


(dmknght) #11

Here is the fix

  1. Login to postgresql, delete username and drop database
    sudo -u postgres psql
    DROP DATABASE faraday; -> (respose DROP DATABASE if complete)
    drop user faraday_postgresql; -> (response DROP ROLE if complete)
    Please notice that this is example, please check your db name and user carefully by press \l in postgre cli
  2. Create new faraday db
    cd /usr/share/python-faraday && python manage.py initdb
    It should show you
Admin user created with 

username: faraday 
password: <Random Password>

p/s: I logged in successfully but faraday client still can’t connect to server. I am trying to fix this issue


(dmknght) #12

palinuro
After minutes of discovering, i think i understand this issue. We are having 2 errors here:

  1. Login cred, which can be modify and reconfigured (my above comment)
  2. Connection error:
    By now, python-faraday is using /usr/bin/python-faraday as running script, which has
#!/bin/sh

systemctl start python-faraday
sleep 3
cd /usr/share/python-faraday && ./faraday.py "[email protected]"
systemctl stop python-faraday

Basically, python-faraday.service is located at /lib/systemd/system/python-faraday.service, which has

[Unit]
Description=python-faraday Server
Requires=postgresql.service
After=postgresql.service

[Service]
Type=simple
ExecStartPre=/bin/sh -c 'if ! su postgres -c "psql -lqt" | cut -d \| -f 1 | grep -qw faraday; then cd /usr/share/python-faraday && python manage.py initdb; fi'
ExecStart=/usr/share/python-faraday/faraday-server.py

So i started faraday server as service (which should be okay) by sudo service start python-faraday. I have python-faraday is running by service python-faraday status. I can say faraday server is running.
Next, I opened Browser, go to http://localhost:5985/#/. It directs me to login page, but my new username and password is invalid (?). I go back to /usr/share/python-faraday, run python manage.py status-check, it gives me:

Checking if postgreSQL is running...
[+] PostgreSQL is running
[+] PostgreSQL lock not detected. 

Checking if Faraday is running...
[-] Faraday Server is not running          
[-] Faraday GTK is not running

Checking Faraday config...
[-] Credentials can not be checked. Either Faraday Server not running or database not working
[+] /.faraday/storage -> Permission accepted
[-] Port 5985 in localhost is not open

Service is running, port is opening, but faraday is not working. I stopped faraday server by sudo service python-faraday stop then start server manually python faraday-server.py start. Wow, i logged in successfully.
Check running status again:

Checking if postgreSQL is running...
[+] PostgreSQL is running
[+] PostgreSQL lock not detected. 

Checking if Faraday is running...
[+] Faraday Server is running. PID:6744         
[-] Faraday GTK is not running

Checking Faraday config...
[+] Credentials matched
[+] /.faraday/storage -> Permission accepted
[+] Port 5985 in localhost is open

Fix: here is my /usr/bin/python-faraday. There is no server kill after finish task so user has to do it manually. I’ve checked and there is no error. Please make tests and fix as soon as possible.

#!/bin/sh

cd /usr/share/python-faraday && ./faraday-server.py &
sleep 3
./faraday.py "[email protected]"

p/s: After checking python-faraday server options, server has --stop mode, so maybe adding ./faraday-server.py --stop in the last line of script is good. Or you can make 2 scripts that point to faraday-server and faraday-client and let users run it manually.
p/s 2: create workspace gives me 500 error (i logged in both web inteface and cli). I really need help in this step