Firefox consumes too much CPU

1. Your Parrot information

  • OS version: run cat /etc/*release
    $cat /etc/*release
    PRETTY_NAME=“Parrot OS 4.11”
    NAME=“Parrot OS”

  • Kernel version: run uname -a
    Linux parrot-ng 5.10.0-5parrot1-amd64 #1 SMP Debian 5.10.24-5parrot1 (2021-03-20) x86_64 GNU/Linux


4. How did you get this error? Are there any steps to procedure it?

I installed Parrot on a VM using VirtualBox and I ran into a problem very randomly every once a while. One of the cpu core suddenly go 100% and the system response very slowly. Even typing command on it feels like a struggle. Htop shows that it is firefox which is causing the problem and I have only a dozen tabs opened at the time.

I have used parrotOS and firefox before and have never experience it. The installed extensions are: Cookie quick manager, FoxyProxy standard, HTTPS everywhere, Privacy Badger and uBlock Origin.

5. Error log or screenshot

Have you tried de/re activating add-ons to see if any one of them is related to the issue?

If you have not looked at Firefox task manager yet, you may also want to look there.

Have you installed foxy proxy because i have the same issue i have to stop foxy proxy and restart again


Are you running privacy Badger extension? I thought FireFox was consuming too much CPU and I opened the FireFox task manager and realized that it was privacy badger that was the culprit. Even when streaming video privacy badger was using 5x CPU.

Wondering if you are seeing it too or if it just me?

I experienced the cpu spike again today. Firefox task manager reported no problem at all. Despite that, I tried to disable all the add-on on the fly and it didn’t have any effect, one of the CPU core is locked at 100% and Firefox is still reported to be the culprit. I am using parrot to learn web security so foxy proxy and cookie manager are important to me. Will try to disable the other extensions at the beginning

Privacy Badger is installed by default. I don’t really need it but it’s also not the culprit in my case according to Firefox task manager

Yes, I need that extension though. For now I’m not having problems with chromium and same extensions. I’m wondering if it’s Firefox exclusive

I think the problem is with foxy proxy since am having a similar issue what you van do just use htop and kill that process using much CPU then restart foxy proxy again it’s been woking for me

And watch out for update one of the updates am sure will fix the issue

I experience the same issue, and I dont have foxy proxy installed.
I do have some of the other extensions, and thought one of them was the culprit because after deactivating some of them the problem seemed solved. I was wrong.
Anyway, if you look at the system monitor, the process causing the spike has “extensions” in the name, while firefox monitor itself reports nothing useful at all.

In any case, it may be more of a firefox issue than something Parrot specific.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.