FireFox - Server Not Found

Hi! I’m using (Parrot Securit 4.6) KDE.

Whenever I’m trying to run FireFox normally it keep saying: Server Not Found.
I have tried to access several different websites that I know is up running and working, like YouTube for example but it refuse letting me access. I first tried the (Parrot) named one, then I tried to create a new Personal one but getting the same result there.

So I tried to download FireFox from their (Official Website) to get a clean install of the browser without all the apps installed that comes along with the Parrot version of FireFox but it enforces it into the SandBoxed version with all the apps included.

The main reason to why I need FireFox is to bypass websites that is blocking the Tor browser and not allowing it to access or it wont act or behave properly.

If someone could please help me fix this problem it would be much appreciated.

Thank’s in advance //Best Regards

Hello @ParaX0rmal
Maybe have a look at your dns file. Take a snap of what the resolv.conf files says.

sudo pluma /etc/resolv.conf

Try this and make sure your dns is right. I had similar issues before too. It was a dns issue.

Cheers.

Hi Jessica and thank’s for your reply.

I get this: nameserver 127.0.0.1

We removed DNS list by default because there are users complain about DNS, their privacy and Russia problem (There are quack quack still complain about it even we removed all DNS quack from this ducking list). You can add the DNS list into this file by yourself.

generally for network problems try to reach for example 8.8.8.8 via ping and then with a hostname.
ping 8.8.8.8

ping google.com

this steps are network basic steps!
if the first command works and the second one not you have a problem in name resolusion.

there are tons of articles in the i-net and our forum how to fix this! :wink:

please be creative! :slight_smile:

1 Like

If you have been fooling around with dns stuff and privacy apps you are most likely causing this issue yourself.
Also, you are not stuck to 2 browsers. Even in Synaptic you have Chromium and a few others. TOR browser has a specific purpose, not considered a general all around browser. Most people use it for traveling around the dark or deep web.

You can even install Chrome if you wish.

But follow the advice of the Devs, they put this distro together and they know exactly what they are talking about. I welcome all people who have decided to make the move to LINUX, but especially if you are using a Pentesting distro you really need to learn more about networking basics and possibly beyond to fully understand what you are doing. Hope my two cents helps some… =)

2 Likes

Hello @ParaX0rmal :slight_smile:
The issue you mentioned is usually caused by VPN services and privacy apps.

Also, Did you use anonsurf? make sure to stop it if you did use it. Anonsurf or proxychains changes the resolv.conf file config to 127.0.0.1 aka local host to route through tor.

This should do it for you to stop anonsurf :
sudo anonsurf stop

Once done.

Try to add these in your /etc/resolv.conf file as superuser.

sudo pluma /etc/resolv.conf

trying adding the following lines in the text file

nameserver 1.1.1.1
nameserver 1.0.0.1

Thats cloudflares privacy DNS.

Alternatives are

OpenDNS :

nameserver 208.67.222.222 
nameserver 208.67.220.220

GoogleDNS :

nameserver 8.8.8.8
nameserver 8.8.4.4

Comodo Secure DNS (blocks known malicious sites network wide for free, The one which I prefer for regular use)

nameserver 8.26.56.26
nameserver 8.20.247.20

Finally the /etc/resolv.conf file should look something like this :

conf

Once changed the value of the file. save it and exit.

3 Likes

(Pssst. hey. typo :stuck_out_tongue:)

fixed! thx jessica!

1 Like

I love you <3 It was the Anonsurf that was enabled. I haven’t used it in a while and last time i did i did stop it and PC have been rebooted several times since then. Didn’t know it could enable itself.

Anyways that fixed my problem, thank you you’re the best :slight_smile:

Glad to see that not all people are cocky and unhelpful when someone needs help!

1 Like

@ParaX0rmal

It never got disabled. Its totally user dependent.

Feel free to mark my statement as the solution for rest of the users who may be having similar issues in futute. Like This :

solution

I had similar issues in the past too :slight_smile:
Cheers!

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.