Firefox states 'set default browser'

Firefox is set as preferred Web Browser in the Preferred Applications setting. I have clicked set as default a number of times and yet the dialog keeps popping up.

I have tried setting the web browser as ‘firefox profile manager’ and ‘firefox’. Both the same result.

Using 4.18.0-parrot10-amd64 installed via usb.

Thankful for any help.

Firejail sandboxing prevents firefox from setting default browser, so the dialog will keep popping up.

If you start firefox from the console without firejail : firejail --noprofile firefox
Then go to preferences in firefox (you can type ‘about:preferences’ in the url bar)
Right at the top should be a button that says ‘Make default’ or something similar, press that (It should tell you its now default).

Now whenever you start firefox normally it should be default and wont prompt you again.


Thank you very much

1 Like