[Firmware-Bug + Fix] Intel Wireless AC9560

Applies also to AC 9461 and 9462
After recent upgrades my laptop froze while booting up, looking up the problem I found that the iwlwifi module looped and finally kernel-paniced with

Applying debug destination EXTERNAL_DRAM


FW already configured (0) - re-configuring

The problem is faulty firmware in the fimware-linux=2019717-1 pkg. It is acttually an old Kernel 5.1 bug that was upstreamed again. Hail the intel QA.
The 5.2 Kernel uses iwlwifi-9000 v46 which is the faulty one.
If you boot with acpi=off (if boot freezes) and

cd /lib/firmware
sudo cp iwlwifi-9000-pu-b0-jf-b0-41.ucode iwlwifi-9000-pu-b0-jf-b0-46.ucode

it works again. Just overwrite the faullty version with last one that worked.
Fixed it for me. Took me whole Sunday, only to find out that I could’ve fixed it faster by properly googleing it. :exploding_head:

1 Like

THX for the nice howto!!
i couldn´t test it but it sounds good! :wink:

Maybe some other user can test this?

I have this wifi card in my Aspire A515-52G wifi%20card but I use the live version of Parrot

must wait for fix ISO or new version of Parrot

try it out maybe it even works for kali
do tell us how did it go

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.