First boot no graphics nor root access

Briefly describe your issue below:

I just installed Parrot os on my laptop, no problem.
When i started Parrot for the first time, I just get the try (works pretty well). I tried startx, but the system froze.
I reboot in rescue mode to update, but I got “cannot start apparmor, etc…” and root is no longer accessible.

My laptop is a MSI GE72 6QD with a i7 6th gen and a GTX 960m

What version of Parrot are you running? (include version, edition, and architecture)
I installed the last version of Parrot os, ie. the 4.2.2

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
I used the Debian GTK installation method

Configured to multiboot with other systems? (yes / no)
I have a multiboot with Windows 10. Before installing Parrot I had a dual boot Windows10/Dabian buster Alfa 2.

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:
[FAILED] Failed to start Load Apparmor profiles.
See ‘systemct1 status apparmor.service’ for details.
[…]
Cannot open access to console, the root account is locked.
See sulogin(8) man page for more details
Press Enter to continue.

Okay, I almost managed to fix it!

The lack of a graphical interface was due to watchdog errors (“CPU#3 stunt for 22s!”).

So I added “new.modset=0” at the end of the line beginning with “linux” in the grub script (type “e’”), and it works: I have a graphical interface and everything works.

The start is still a little slow, I’ll keep looking for what’s slowing down.

These commands will help you diagnose slow boot times.

1 Like