Fix missing firmware for bluetooth

Since last few days, i was getting the following error while booting the system -

[ 27.712080] bluetooth hci0: firmware: failed to load brcm/BCM20702A1-0a5c-21e6.hcd (-2)
[ 27.712088] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware

I ignored it because it never caused any problem untill today, when i tried to connect to other device via bluetooth. solved it by little bit of searching.

Now here is a quick guide to fix it :
Check which firmware is missing -

sudo dmesg | grep -i bluetooth

Now go to this link, and copy the link to approriate .hcd file (in my case it’s BCM20702A1-0a5c-21e6.hcd).

Now copy the BCMxxxxxx-xxxx-xxxx.hcd file -

cd /lib/firmware/brcm/
sudo wget https://github.com/winterheart/broadcom-bt-firmware/blob/master/brcm/BCM20702A1-0a5c-21e6.hcd
sudo modprobe -r btusb
sudo modprobe btusb

Now reboot and check the output of sudo dmesg, and test wether it’s working or not by connecting your system to other device.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.