Font Render problem

Briefly describe your issue below:

After update many parts of the system font are not rendering .tried changing fonts but doesn’t fix this…2020-04-25_15-34

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Parrot sec 4.8(kde)
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Debian standard
Configured to multiboot with other systems? (yes / no)

no

Briefly describe your issue below:
I just update parrot OS and when the update was installing i saw what is in the picture attached the fonts are kinda idk what it is exactly

What version of Parrot are you running?
Linux parrot 5.4.0-4parrot1-amd64 #1 SMP Parrot 5.4.19-4parrot1 (2020-02-27) x86_64 GNU/Linux its KDE variant

What method did you use to install Parrot?
Debian GTK

Configured to multiboot with other systems?
yes

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

So is there some fix to it as it renders os non usable completely :frowning:

Haven’t found any solution. :slightly_frowning_face:

Another update came and i just finished updating but still the issue is there

It may be the application problem.

It’s with every single application except file manager and a few. Everything was working fine untill i updated parrot yesterday.
Is there any way to rollback?

No to roll back, you need to setup timeshift. For that, you have to create a point before the point which is not possible now.
May be reinstalling will work.

No way i can reinstall whole os i spent quite a time on configuring everything the problem is with the gtk system rendering font, maybe. it somehow does not renders the font don’t know why
Like i use vscode i open it it looks normal but when i choose to open a file or folder the madness comes up
It all started after the update everything was perfectly find untill then
And even when using preinstalled application if i choose to open something it again does not render fonts perfectly and some other applications do not work as well it must be something related to the way fonts are behaving I don’t know much about linux but this is what i think possibly be happening

I’ve been having the same issue.
Please let me know if you’ve found a solution.

I’ll give an update in this thread as well if I find something.

This is my thread:

2 Likes

This can be the discussion thread for font render issue since it has the most replies (please be sure to search before posting new topics: a friendly reminder, other ppl posted multiple topics on this)

I have pinned this topic for 1 week and transferred the latest post on font render problem (including screen shot) to 4.8 bug reports thread to make sure it gets proper attention:

https://community.parrotlinux.org/t/parrot-4-8-bug-report/12224/16

If you have anything important to add the above link is the thread to add important info, but only if you have additional info to add. I am going to temporarily pin this thread for discussion and delete others that have no additional info to add. :wink:

2 Likes

Same issue occured after update today. Parrot 4.9

1 Like

same here, Parrot 4.9 KDE Plasma

2 Likes

I think the issue is based on the software, I encounter the issue in mozilla but in brave browser its working fine. Also, when I tried to attached file in thunder, issue occurred. Some of my application encounter the same issue like filezilla and remmina. I think it depends on the software of the OS.

These softwares come pre-installed but still they arr having issues they worked fine before it is not related to software itself since it’s happening system-wide also file manager is having problem too then does that mean to remove it as well?

Try Regenerating the fonts cache :
sudo dpkg-reconfigure fontconfig fontconfig-config
You can also run this as a user with fc-cache -fv

that did not work

I’m sorry to be asking here, but the bug report thread is closed and my personal thread has been hidden. So I don’t know where to post.

I guess they closed the bug report thread because somebody posted a solution, you should change the font in **KDE system settings, selecting Application Style and then Gnome/GTK Application Style.

But I can’t find those settings anywhere. It is possible that they are here but I simply can’t read them because a lot of my system is in those strange characters.

Is there a way that I can easily reach those settings?
a command, or a pictogram I can recognize if the text is not readable?

Thanks!

Have you tried reconfiguring font package?
To do that run this command
sudo dpkg -reconfigure fontconfig-config
and try rebooting