GNS3 Install

Briefly describe your issue below:
I am having trouble installing GNS3. I have read other forum posts that say to use pip3 install gns3-server. But when I run that I get the following error:

psutil/_psutil_common.c:9:10: fatal error: Python.h: No such file or directory
9 | #include <Python.h>
| ^~~~~~~~~~
compilation terminated.
error: command ‘x86_64-linux-gnu-gcc’ failed with exit status 1

Failed building wheel for psutil

Can’t roll back psutil; was not uninstalled
Command “/usr/bin/python3 -u -c “import setuptools, tokenize;file=’/tmp/pip-install-p4sqq4lm/psutil/’;f=getattr(tokenize, ‘open’, open)(file);’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-record-kzyx30q1/install-record.txt --single-version-externally-managed --compile” failed with error code 1 in /tmp/pip-install-p4sqq4lm/psutil/

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)

Parrot GNU/Linux 4.7

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
Saw some other posts about installing GNS3, but some were super old, or not applicable to my error.

If there are any error messages or relevant logs, post them below:
Posted above.

why do you try to install. gns3?
normaly a networksimulator should be started via hypervisor like vmware or virtualbox.

1 Like

I had trouble running the VM version when the hardware was running Windows. But when I installed it it ran great. So I was going to continue using the program and not the VM. I can try installing the VM tomorrow and see if it works.

why pip and not apt?

sudo apt intall gns3

@palinuro because I read this forum post before attempting install:

DMKnight said to use pip. But I still get the same error when using apt. So either way, same result.

@rowie I was able to install the VM and run it. I think I need to reconfigure the network settings on the VM. After that though, I don’t know how to use the VM versus the local install.

you have to install the client and then you could select local server or remote.
i have the client running on win10 and the server is running on my esx server.
i think there is a really good docu. and nice videos on youtube from David Bombal:

1 Like

Sweet! I’ll check that out when I get some spare time. I have seen all the documentation for the client but haven’t seen much for the VM. I’ll check out his videos and see what I can break…errr…come up with…lol

1 Like

Those are some awesome videos. But he installed it on a Windows 10, which is what I had it installed on before re-imaging to Parrot. He was able to install the GUI easily and run up a small network. I have not been able to install the GUI due to the errors above.

Maybe I need to try straight from the gns3 website as opposed the Parrot repository? What do you think about that?

So, I just got it to install.

I ran sudo apt install gns3 and it took and installed without issues. No idea why. May be my internet connection out here was acting up cause of weather (I have satellite internet).

I know I’ve tried that command before and it didn’t take. I read the GNS3 manual and it says to use other ways. I dunno. Whatever, it works now. I feel dumb but at least it works.

I’ll be subscribing to that youtube channel to follow the rest of his videos. He’s got some good stuff. Thanks!

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.