Graphic problems i suppose

I took pictures to describe best my problem here.
I installed Parrot recently and my only problem looks to be a graphic one.
When i open a window, a terminal or firefox, it went ok but when i close it, i have a screen tearing problem all the time. I tried to go to /usr/share/X11/xorg.conf.d/10-radeon.conf … to edit the driver with Option “TearFree” “on” but nothing changed with that…
Can someone help a bit ?
Thanks :slight_smile:

02

Actually when I use I get this issue an some time it’s getting restart half hour later why it’s happening u don’t know but when I use the dvi port it’s good…

Hey :slight_smile:
Sorry but i’m not a linux champion, i can basically look for help on google and follow things.
I don’t really understand your answer.
How can i use the dvi port ? Command line ? Something to do ?
Thanks

Have you ever installed bumblebee?

Do you have two graphics cards, or just one? If so, what card is being used for desktop? Give me the output of lspci | grep VGA and lspci | grep 3D.

If you have two cards also check out fglrx driver.

Hey :slight_smile:
I did an apt-get update and an apt-get upgrade so it took some time. Now it’s over
I did what you asked me and took a picture.
I’m currently installing bumblebee btw
In this picture i took my wholw screen cause i can see some other errors maybe it will help somehow

Even after bumblebee installed i still have the same bug.
I open a terminal window and when i close it, i have the graphic bug immediately :frowning:

Looks like you have only one graphics card. You don’t need bumblebee then, do sudo apt purge bumblebee. Have you tried to search for your card graphics drivers? I am not an expert in AMD drivers installation.

Well i tried indeed ! But couldn’t find compatible one in a way. It was written OS not supported or something like this.
I can’t be the first to have that kind of problem ??

In my mother board there is inbuilt dvi Port I use tat it’s not getting reboot if I use graphic card with vga cable it’s getting restart I have vga cable so I bought that dvi to VGA cable

Oh i see. Well i have a lap top and would like to use as a laptop ! :slight_smile:
It must be a way to solve this bug !
I will try other forum as well !

Okey ! I won’t do it again then but the graphic bug was there before i ran this command anyway :frowning:

1 Like

inxi is really great yes
I will follow what you told me and reinstall this way
Thanks, i will post the result here :slight_smile:

1 Like

So i re-installed Parrot and did the “sudo parrot-upgrade”
After a reboot, the graphic bus is still here.
I tried to install the AMD drivers like you said in this link https://www.parrotsec.org/docs/info/gpu-drivers/
It said that both the drivers and the firmware are already updated .
Any other ideas ? How can i fix this ? :frowning:

1 Like

Mm Ok , See In Graphics Setting
I also have this problem 6-7 month ago
I go to setting & change something (i forget now)

You can also try to reinstall parrot-mate

sudo apt remove --purge parrot-mate parrot-interface xorg && apt install parrot-mate parrot-interface xorg && parrot-upgrade

Maybe disable the nouveau an install nvidia

Hello everyone, so i have an other clue that may help you understand the problem better than me.
When i just open mate tweak, the screen is tearing. The graphic bug still here.
Even with the screen tearing, i plugged an other screen (HDMI) and use the mirror screen (Can see the same picture on both screen) and there the screen tearing disappeared !!!
So i unplugged the HDMI screen and now the bug is no more, i can do whatever i want, no more screen tearing BUT if a restart parrot, the bug will be here !
Strange ! What could it be ?

So it sounds to be a bit like you said !
How did you make it disappear for good ?

What you mean by installing nvidia? He has AMD graphics card…

Better he can remove the Card an use it as mother board slot for display it’s working better

I just mean that when i plus a HDMI wire, it makes the screen back to normal !
After i just unplug it and i can do whatever i want with parrot, no more graphic bug !
But i restart the system, the bug is still here and i must do it again, plus a HDMI wire and unplug it…
Would like to know if it helps you guy to understand the problem ??