Grub disapeared

**What version of Parrot are you running? 4.8 security mate amd64
What method did you use to install Parrot? Debian GTK
Configured to multiboot with other systems? yes with windows 10

link to my previous topic bellow for which i did not got any help or reply

my new issue is now the grub has disapeared and i can only boot from super grub disk or with the help of another linux that i have installed on my external hdd
i tried installing reinstalling grub by
#grub-install /dev/nvme0n1p6
Installing for i386-pc platform.
Installation finished. No error reported.

Generating grub configuration file …
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-5.5.0-1parrot1-amd64
Found initrd image: /boot/initrd.img-5.5.0-1parrot1-amd64
Found linux image: /boot/vmlinuz-5.4.0-3parrot1-amd64
Found initrd image: /boot/initrd.img-5.4.0-3parrot1-amd64
Found memtest86+ image: /memtest86+.bin
Found memtest86+ multiboot image: /memtest86+_multiboot.bin
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration
Found memdisk: /memdisk
Imagepath /boot/images not found

but no change I dont get parrot grub screen on reboot


Grub disappeared? what are you seeing at boot? Blank black screen w/blinking cursor? or something else?

it directly boots to windows10

Sounds like Windows boot manager is still prioritized to boot.

Try this tutorial that meets your description:

Let me know if it works for you.

already tried it doesn’t work

What are your BIOS options? If set to UEFI make sure secureboot is set to off otherwise Linux will not boot.

If this does not work it may be worth trying a Legacy BIOS setup/if you have that option (I am former UEFI user currently using legacy setup).

secureboot is already disabled thats how i boot from usb drive and I’m using legacy bios setup

have you tried updating the grub from a Live stick?

yes i did updated grub using live stick and directly from parrot os but no change

So you on UEFI?

legacy enabled

thanks for your support

this video seems to have solved my problem

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.