GRUB Not Installing from Live Boot USB


(Toby Hinshaw) #1

Briefly describe your issue below:


What version of Parrot are you running? 4.3 i386 (ISO)

What method did you use to install Parrot? Tried normal installation and GTK - also had same issue trying to install Kali.

Configured to multiboot with other systems? No - attempting clean install on older laptop. Levono Ideapad 100 11iBY (32 GB internal memory card as hard drive)

If there are any error messages or relevant logs, post them below:
Boot loader will not install, so I skip it and get the following message:
You will need to boot manually with the /vmlinuz kernel on partition /dev/mmcblk1p2 and root=/dev/mmcblk1p2 passed as kernel argument.

Any help to either 1) get GRUB installed or 2) teach me how to manually boot.

I am obviously new to Linux - I have installed it in VM and on Raspberry Pi, but can’t get it to physically install to the laptop.


(Matt) #2

I had some problems with grub installations before and solved them by just changing the partition sizes, leaving a bit extra space.

You could install grub using chroot:
If you plug in your installation USB there will be a ‘live mode’, start that. Then have a go at: https://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd

You can boot linux without a bootloader (grub) but it wouldnt be the easy option. Im not sure if the parrot kernel even supports it with its current config.


(Toby Hinshaw) #3

I’ll try another install and leave some free space. Thanks for the suggestion!


(Toby Hinshaw) #4

Still no luck. What is the option for Reserved BIOS boot area? I’m going to give that a shot.


(Matt) #5

Im not sure i know what you mean.

The boot partition is called ‘boot’ or will have the boot flag. To change the sizes: when you get to the ‘Partitioning method’ screen, choose ‘Manual’.


(Toby Hinshaw) #6

Following the instructions from the link you provided - it uses a command grub-install, but I get a return if “command not found”. I have googled it and tried to resolve it, but I am stumped.


(Matt) #7

hmmm it should be installed.

Make sure you are passing it the correct drive.
If you type ‘grub-’ into your command line then hit TAB a couple of times, it will list all the available commands starting with ‘grub-’, including grub-install hopefully. But if not sudo apt-get install grub2-common will install if.


#8

its not a parrot bug, its a bug of debian-installer project. in this moment i build alfa of WarTech 3.0 Linux (based on buster, not stretch) and have same issue.


#9

Hi,
I will explain what to do:

  1. Install parrot without bootloader;
  2. After installation run Parrot from live usb and connect it to internet;
  3. Open terminal and go in chroot mode whit theese commands:
# mount /dev/sda1 /mnt (replace sda1 with your root dev)
# mount -t proc proc /mnt/proc
# mount -t sysfs sys /mnt/sys
# mount -o bind /dev /mnt/dev
# chroot /mnt
  1. Update repository on chroot environment with #apt update
  2. Install grub with # apt install grub2
  3. Follow istructions on the screen and you have solved your problem
  4. Close chroot environment:
# exit
# umount /mnt/{proc,sys,dev}
# umount /mnt

P.S. If you get a message like this: “temporary failure in name resolution” when you exec apt update, you need to kill dhclient and insert manually required nameservers with this commands:

# killall dhclient
# rm /etc/resolv.conf
# nano /etc/resolv.conf

Into file insert this line: nameserver 8.8.8.8 (or your preferred DNS). Save and close file with Ctrl + X

I hope theese info will help you


(Toby Hinshaw) #10

Wow, thank you for giving such a detailed explaination. I will try these steps today. I was able to get Kali Light to load onto the laptop, but I would rather have Parrot on it, so really hoping I can get it figured out.


(Toby Hinshaw) #11

Ah… the dhclient is something I haven’t done! Progress.


(Toby Hinshaw) #12

That all worked perfectly, then I rebooted and received the message = “No Bootable Device. Hit any key.” I think this laptop is having way more fun messing with me than I am with it! :tired_face:


(Ali Abdullah) #13

I had the same Problem, and here is the way i fixed it.

I own an Asus X200M (Do not Recommend it)
First i knew Installing Parrot Security OS on UEFI was hard as i have had alot of Problems Doing it, so i went to my BIOS Menu and there was no option to Enable Legacy Boot Mode, so i Thought of Updating my BIOS With this method:
You will need a spare USB any size is Ok.

in your case, since you have Lenovo 100 11iBY

Search Lenovo 100 11iBY Then get the latest BIOS Version you can find, you will often find it on Lenovo’s Own website, the File’s Extention will be a Random number.

Extract the File to Your USB, make sure you can boot from the USB.

Shutdown your laptop and go to your BIOS Menu, Turn on Launch CSM, Then Start Easy Flash.
Make sure your USB is Plugged in First.
Search for the File that you Extracted into the USB and Hit Enter while it is Marked, select Yes when it asks for BIOS Update.

This process shouldn’t take any longer than 3-5 minutes depending on the Size of the Update and your Computer’s Performance, Keep in mind your Battery should be atleast 20% and Plugged in Using the charger.

After it is Done, Reboot into your Installation Media and Preform a Reinstallation of Parrot Sec OS, it should work Just fine for you, as it did for me.


(Toby Hinshaw) #14

Ali - I will give that a shot… I had thought about the bios, but brushed the idea away.


(Ali Abdullah) #15

Alright, Tell me if it Works!


(Ali Abdullah) #16

Sorry i had mistyped this:

Search for Lenovo 100 11iBY *Drivers*


(Toby Hinshaw) #17

Another kick in the teeth - their bios update is a utility (exe) that you must run from within Windows 10. I searched to see if I could find other alternatives, but no luck… but that was a very good idea!


(Ali Abdullah) #18

ah, that sucks, i don’t know if i can help you any further, i am not an expert. try to install Parrot OS on your Main PC and then try to boot the hdd on your Laptop, that is if you are installing it on an External HDD like i am, otherwise, good luck.


(Amzker Pro Hacker) #19

Just use Etcher
For making bootable USB
ALL problem solved During Installation Occures