Grub not loading Manually loading Parrot

I installed Parrot Os manually and have no other OS. Whenever I start my lenovo B570e it shows PXE061 error and doesn’t show Boot menu in boot opitons. Therefore, I have to plug-in USB everytime and type following command to boot parrot os:

set root=(hd1,gpt3)
linux /boot/vml…
root=/dev/sda3
initrd /boot/initrd…
boot

So, my query is that whether there is any way to automate such thing. Please help trying to solve for more than 3 days…

Hi @Hamza_Waheed,

You can modify grub settings in /boot/grub/grub.cfg

After modifying, run sudo grub-update

Thanks for early reply,
So should run this command in live or after loading in OS?

After loading OS.

It could be a boot order issue since it’s a PXE error. When you go into BIOS, what is the boot order?

Please rectify me, if I’m wrong because I am literally newbie:

1s is USB
2nd is HDD on which Parrot OS is installed only

That seems to be ok. May have been an issue if Network Boot / Boot from LAN was first.

I’d try modifying and updating the GRUB config file and see how that goes.

Can I share my grub.cfg file with you and tell me what is wrong OR you could teach me how to modify grub.cfg so I don’t have to type the above said commands again and again…

The best way to learn Linux is to read as much documentation, and other materials, as you can and try to solve problems yourself before asking someone to do it for you. You will learn MUCH faster this way.

For GRUB, you can read the GNU manual: https://www.gnu.org/software/grub/manual/grub/grub.pdf
or in terminal type man grub

For Linux learning in general: http://linux-training.be/

One more thing, in BIOS can you disable PXE boot and try again?.. assuming you don’t need it for anything.

Thank you for your advice and time. I will work on it.

Boot up and fix grub & install it

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.