GTK in Geany?

Hey parrot people,
I’m relatively new to parrot, and I was trying to start using the pre-installed geany to make GUI programs with GTK in C++. When I “#include <gtk/gtk.h>”, it says “no such file or directory”. I notice there is a “gtkcompat.h” in my “/usr/include/geany” directory, but even in the code of that it tries to “#inlude <gtk/gtk.h>”.

I don’t see a “gtk.h” located anywhere on the system.
Am I missing something here?
Am I being dumb?
Do I need to configure or build it or something?

Fresh install of Parrot 4.7 security on amd64
Installed from usb
Dual boot with windows
Seperate partition for /home

Bonus junk I’ve tried:
I know parrot’s pretty sensitive with updating things, but I tried just installing gtk (and dependencies) as if it doesn’t have it. Part of the way into the dependencies the system wouldn’t boot.

sudo apt install libgtk-3-dev

source -

1 Like

Getting some errors.
E: Failed to fetch Hash Sum mismatch

trying dpkg -i <blah.deb> to install the package manually tells me it’s not a Debian form at archive

Clear the apt cache -

sudo rm -rf /var/lib/apt/lists/*

then run sudo apt update, after installing libgtk-3-dev check if gtk.h exists or not by running -

└──╼ $find /usr/include/ -iname gtk.h

Still nothing. Still failed to fetch and gtk.h still doesn’t exist…

Post error logs/screenshot.

messages.gz (494.3 KB)
I hope that’s what you’re looking for

Soooo shortly after that post, I just tried apt install libgtk-3-dev again and it worked…
I don’t think anything I did modified anything. I’ve got a gtk.h now. maybe it just needed a restart?
Not sure how, but thanks for your time mate.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.