GTK installer not showing up

Please complete our guideline for issue report or idea suggestion

If you are having an issue, please follow this

There are many kinds of issues: OS, software, server, … So you must know:

  • Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
  • 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
  • Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
  • This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
    Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:
  1. Basic Linux: http://linux-training.be/
  2. How to not break Debian system: DontBreakDebian - Debian Wiki or How NOT to Break your Debian System! | Average Linux User
  3. If you are having some questions, your answers might be in here: FAQsFromDebianUser - Debian Wiki
  4. Your issue might be solved before (StackOverflow is a temple), try this: https://www.searchenginejournal.com/search-engines/answering-questions/

1. Your Parrot information

  • OS version: run cat /etc/*release
    Copy output here
  • Kernel version: run uname -a
    Copy output here

Or if you can’t do it, please tell us ISO version you downloaded.

** ISO information **

Version: 4.9
Desktop Environment: Mate
Edition: Home

2. If you have this problem after fresh installation:

  1. How did you create USB bootable?
    I used Rufus and downloaded Parrot MATE edition from direct download.
    I selected GPT for Partition Scheme on Rufus

    • Software was used to make USB
    • Steps of making USB bootable
  2. How did you install OS?

    • Debian installer or Calamares installer?
      Debian I believe

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

Hardware information

- Your device name or output of `lspci`
```HP Pavilion 
    Copy output here
```
- Did you try searching info about this issue on search engine? Please write **No** or any URL to this issue bellow

Yes but no information

4. How did you get this error? Are there any steps to procedure it?

1. I installed this: ![image|666x500](upload://gYw7bp7JKPQR7bQoKb0f8GfvtZH.jpeg) 
2. I ran this new software
3. It shows me this: ![image|375x500](upload://bV2M4k67y6zlGfnkNjD7uNV54OR.jpeg) 

5. Error log or screenshot


GTK does not show up I believe it is installed.

6. If you have any idea or suggestion about this issue please tell us

If you are having suggestion for our OS, please write it bellow

1. Current Parrot version 4.11.1

2. Its section and how it affects our system

  • Pentesting / Forensic / Malware hunting / Privacy protection / …
  • It is: AppArmor profile / software / system service / kernel module…
  • when user runs this / start that, it can do…

3. Any other information about this idea

You can use installer from live mode :slight_smile:

I heard it fucks with ram and is not permanent

I prefer to use gtk as thats what I’ve been told to use

The gtk installer is accessed through live mode. The live mode lives in RAM and does not persist, but the installer that you will access through live mode is the same gtk installer that will be displayed if not in live mode.

There is only one gtk installer. Two ways to access it.

are those the 2 ways?

We are using Calamares installer.

Im so confused

Did you boot into live mode and find the installer desktop icon?

Describing what exactly you are confused about would be helpful.

1 Like

I did yes. But i heard live is not good, and ruins RAM and is temporary not permanent. I boot up the OS, get to the Live and Advanced screen and see no GTK installer. When i went into live, i installed and didn’t go any further as I was told live is not what i want.

Adam,

Using the GTK installer (the desktop icon) in live mode will install the exact same Parrot system as a GTK installer activated while not in live mode.

Live mode is just a means to deliver the installer. Once you go through the installation process you will reboot your system (remove the installation media) into the standard Parrot (not live).

1 Like

Ok thank you. When I get to that screen and the OS screen with install and when I’m installing it where do i go to install gtk

My main question is that GTK originally did show up when I first did install but had to reinstall due to mounting issues, and when reinstalled it didn’t show GTK on that screen, in the image, like before. So I assume I access Live, go to GTK after installing and wiping the USB of data to install Parrot onto it?

So, with that detail I am not so sure. I believe that going into live mode and running the GTK installer (calamares) will get you where you want to go.

1 Like

Calamares is not GTK installer. It is developed with Qt btw

Thanks for the correction, dmknight.

I was trying to help and got out of my depth.

So what do I need To do to access GTK when I boot up live?