GTK3 Bug


#1

I sent a bug report, All I could do was send a package name. I’ve been running Parrot since 4.3. Many reformats. I have found that after a reformat, during an update, I get several of these errors. As many as 8 times on a large update.

debconf: unable to initialize frontend: Gnome
debconf: (Can’t locate Gtk3.pm in @INC (you may need to install the Gtk3 module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.28.0 /usr/local/share/perl/5.28.0 /usr/lib/x86_64-linux-gnu/perl5/5.28 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.28 /usr/share/perl/5.28 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 151.)
debconf: falling back to frontend: Dialog
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline

After a reformat, if I install libgtk3-perl, then update, I get no errors. It makes me wonder if there are errors, because of this package missing, that occour during initial setup. It would explain some issues I am having. I am using the Home edition, AMDx64, no dual boot, and I have to use the GTX Installer. Thanks.


#2

Maybe give it 1 bump before it fades away. Seems important to me.


(Lorenzo "Palinuro" Faletra) #3

hi, could you please help us reproducing the bug?


#4

The only log I have is one I copied and pasted onto a Libre Office .odt file. I can’t seem to upload it, but I could copy and paste it if you want, its 34 pages long , Also converted to PDF. Tried to send it PM, but to many words. But if there is something other you would like me to do, I will be glad to reformat and run the updates again.


(Lorenzo "Palinuro" Faletra) #5

o.o a pdf? why don’t you just paste the output to pastebin and give us the logs?


#6

https://pastebin.com/0sAq472T


(Lorenzo "Palinuro" Faletra) #7

there is no gtk3 bug there, just some debconf warnings that can be ignored


#8

Why do I Not, have the debconfig warnings, if I install the libgtk3-perl module before I upgrade?