Hashcat "No devices found/left."

Briefly describe your issue below:
I’m trying to run hashcat but I am greeted by the “No devices found/left.” error. I tried running “sudo apt-get install nvidia-cuda-toolkit” but that makes it so the OS won’t boot upon restart. I then have to fix it by running “sudo apt remove --purge nvidia*” in recovery mode. I tried installing that with clinfo as well and get the same result.

Desktop PC
CPU: i7-4790
GPU: GTX1080Ti
Mobo: Asus Z97-K
Memory: 16GB

What version of Parrot are you running? (include version, edition, and architecture)
ParrotOS version 4.6, Security edition, x64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Live + Installer ISO

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:
Hashcat >> No devices found/left (Made a new thread at the request of KidKlown)

If there are any error messages or relevant logs, post them below:

  • Device #1: Not a native Intel OpenCL runtime. Expect massive speed loss.
    You can use --force to override, but do not report related errors.
    No devices found/left.

Hi! It is possibly your driver is missing opencl. Have you tried install opencl driver for nvidia and install nvidia driver for hashcat on linux on google (and hashcat forum)? I played around with hashcat and driver before but with intel onboard card only (i don’t have nvidia sadly) so i have no experience about Nvidia devices.

Yes unfortunately, I ran sudo apt install -y ocl-icd-libopencl1 nvidia-driver nvidia-cuda-toolkit which makes the OS unbootable :confused:

I see. We should not install it by now. Let me ask other admins (I believe there are users installed driver sucessfully)

Okay thank you :slight_smile:

Did anyone you talked to have a solution?

Sorry man i didn’t see anything from other admin

I’ve found this funny topic, Kali (Linux) is replaced by The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali). Because both Kali and Parrot are Debian-base distro so i guess your problem is from Debian side.

I can run it just fine on Linux Mint which is also Debian-based, so I don’t believe that the issue is that Parrot is Debian-based.

Actually Linux Mint is a Ubuntu-based which is better in Nvidia driver handling (ofc, Ubuntu is a distro that aims regular users). Linux Mint has a Debian-based version also but it is new and I haven’t used it yet. I hope we can improve our driver management but we are lacking human resource, and license bla bla is important too.

I just upgraded to Parrot 4.6 which is supposed to have better support for drivers. I run into the same problem when attempting to use hashcat… So is hashcat even supported?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.