HDMI problem on 2 screen

Please complete our guideline for issue report or idea suggestion

If you are having an issue, please follow this

There are many kinds of issues: OS, software, server, … So you must know:

  • Server issues will be fixed after report and we verify the problem. There will be no update patch for you. It is server side.
  • 3rd party software / packages can’t be fixed by us. If we can spot the bug and have the fix, we will create merge request to original source and wait for their official version.
  • Life is hard. For bug/ issue, please make sure your topic is only one. Dont make developers be terrorists.
  • This is a rolling distro. Bugs and issues are expected. We recommend you have basic linux knowledge to deal with your system, so
    Usually we don’t support issues that user faces by using his system in a wrong way. If you are new to Linux, make sure you didn’t make any mistake:
  1. Basic Linux: http://linux-training.be/
  2. How to not break Debian system: https://wiki.debian.org/DontBreakDebian or https://averagelinuxuser.com/how-not-to-break-your-debian-system/
  3. If you are having some questions, your answers might be in here: https://wiki.debian.org/FAQsFromDebianUser
  4. Your issue might be solved before (StackOverflow is a temple), try this: https://www.searchenginejournal.com/search-engines/answering-questions/

1. Your Parrot information

  • OS version: run cat /etc/*release
    cat /etc/*release DISTRIB_ID=Parrot DISTRIB_RELEASE=4.10 DISTRIB_CODENAME=rolling DISTRIB_DESCRIPTION="Parrot 4.10" PRETTY_NAME="Parrot GNU/Linux 4.10" NAME="Parrot GNU/Linux" ID=parrot ID_LIKE=debian VERSION="4.10" VERSION_ID="4.10" HOME_URL="https://www.parrotsec.org/" SUPPORT_URL="https://community.parrotsec.org/" BUG_REPORT_URL="https://community.parrotsec.org
  • Kernel version: run uname -a
    Linux lx-ricci 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux

Or if you can’t do it, please tell us ISO version you downloaded.

** ISO information **

Version: 4.10
Desktop Environment: Mate
Edition: Parrot Security MATE ISO

2. If you have this problem after fresh installation:

  1. How did you create USB bootable? Yes

    • Software was used to make USB (rufus)
    • Steps of making USB bootable
  2. How did you install OS?

    • Debian installer or Calamares installer? Calamares

3. If your hardware doesn’t work: wifi doesn’t show, graphic issue:

Hardware information

- Your device name or output of `lspci`
```
    00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)

00:01.0 PCI bridge: Intel Corporation 6th-9th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 07)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:15.0 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #0 (rev 10)
00:15.1 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #1 (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:17.0 SATA controller: Intel Corporation Cannon Lake Mobile PCH SATA AHCI Controller (rev 10)
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #9 (rev f0)
00:1d.4 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #13 (rev f0)
00:1d.5 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #14 (rev f0)
00:1e.0 Communication controller: Intel Corporation Cannon Lake PCH Serial IO UART Host Controller (rev 10)
00:1f.0 ISA bridge: Intel Corporation HM470 Chipset LPC/eSPI Controller (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
06:00.0 Non-Volatile memory controller: Intel Corporation SSD Pro 7600p/760p/E 6100p Series (rev 03)
07:00.0 Network controller: Intel Corporation Dual Band Wireless-AC 3165 Plus Bluetooth (rev 99)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

```
- Did you try searching info about this issue on search engine? Please write **No** or any URL to this issue bellow

4. How did you get this error? Are there any steps to procedure it?

1. I installed this
2. I ran this new software
3. It shows me this or that

5. Error log or screenshot

** Insert error log and screenshot here**

6. If you have any idea or suggestion about this issue please tell us

** Your information **

If you are having suggestion for our OS, please write it bellow

1. Current Parrot version and Parrot version you want it has

2. Its section and how it affects our system

  • Pentesting / Forensic / Malware hunting / Privacy protection / …
  • It is: AppArmor profile / software / system service / kernel module…
  • when user runs this / start that, it can do…

3. Any other information about this idea

I would like your help about using an external monitor with parrot security linux.

unfortunately I couldn’t solve this problem and I can’t understand why it doesn’t work.

1- When I turn on the Lenovo Legion Y530-15ICH notebook the parrot image show with a blue background on the 2 screens, but after show only on the notebook screen.

2- This machine has a GeForce GTX 1050 Ti Mobile video card and the drives are installed and working.

3- the Nvidia application recognizes the Dell INSPIRON ONE external monitor but the image does not appear. The status of the monitor is liked disconnected.

4- If someone can help me, you could call me in private.

If necessary i can put anydesk

Here is more information:

$uname -a
Linux lx-ricci 5.7.0-2parrot2-amd64 #1 SMP Debian 5.7.10-1parrot2 (2020-07-31) x86_64 GNU/Linux

sudo lspci | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)

sudo lspci -s 01:00.0 -v
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Lenovo GP107M [GeForce GTX 1050 Ti Mobile]
Flags: bus master, fast devsel, latency 0, IRQ 146, IOMMU group 1
Memory at a3000000 (32-bit, non-prefetchable) [size=16M]
Memory at 90000000 (64-bit, prefetchable) [size=256M]
Memory at a0000000 (64-bit, prefetchable) [size=32M]
I/O ports at 4000 [size=128]
Expansion ROM at a4080000 [virtual] [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [250] Latency Tolerance Reporting
Capabilities: [258] L1 PM Substates
Capabilities: [128] Power Budgeting <?>
Capabilities: [420] Advanced Error Reporting
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Capabilities: [900] Secondary PCI Express
Kernel driver in use: nvidia
Kernel modules: nvidia

$sudo tail -f /var/log/Xorg.0.log
[ 6725.397] (II) modeset(0): EDID vendor “BOE”, prod id 1792
[ 6725.397] (II) modeset(0): Printing DDC gathered Modelines:
[ 6725.397] (II) modeset(0): Modeline "1920x1080"x0.0 152.60 1920 1968 2000 2230 1080 1083 1089 1140 +hsync -vsync (68.4 kHz eP)
[ 6744.647] (–) NVIDIA(GPU-0): Dell INSPIRON ONE (DFP-4): connected
[ 6744.647] (–) NVIDIA(GPU-0): Dell INSPIRON ONE (DFP-4): Internal TMDS
[ 6744.647] (–) NVIDIA(GPU-0): Dell INSPIRON ONE (DFP-4): 600.0 MHz maximum pixel clock
[ 6744.647] (–) NVIDIA(GPU-0):
[ 6744.650] (II) modeset(0): EDID vendor “BOE”, prod id 1792
[ 6744.650] (II) modeset(0): Printing DDC gathered Modelines:
[ 6744.650] (II) modeset(0): Modeline "1920x1080"x0.0 152.60 1920 1968 2000 2230 1080 1083 1089 1140 +hsync -vsync (68.4 kHz eP)

tela01

same issue for me too i have a gtx 1050 graphic card

Similar issue on Gigabyte Aero 15x (intel+nvidia 1070)