hello lovely people ALFA AWUS036NEH

My wifi adapter shows in iwconfig, but not ifconfig. network manager sees it but says device not managed or disconnected and shows no networks.

ALFA AWUS036NEH Long Range WIRELESS 802.11b/g/n Wi-Fi USBAdapter
This adapter used to work without any issue.
I have tried installing firmware and drivers. I have tried adding drivers to blacklist after seeing dmesg -
[ 436.525836] ieee80211 phy3: rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0404 with error -71
[ 437.752679] ieee80211 phy3: rt2800_wait_csr_ready: Error - Unstable hardware
[ 437.752710] ieee80211 phy3: rt2800usb_set_device_state: Error - Device failed to enter state 4 (-5)
I have tried using it through command line but it never finds networks.
I DID get it to connect my adding in the bssid and password to a config file, but i really want it to play around with monitor mode.
Ive really tried my best to get it working on my own, but now i am coming to you for help.

Is this a conflicting driver issue?

Parrot 4.9.1

Debian Standard installation

sole installation
when using the adapter on my desktop, also parrot 4.9.1, it is same problem, adapter still works on windows

If there are any error messages or relevant logs, post them below:

lsusb find the device
iwconfig finds the device

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.