Help - Driver for Realtek 8821au?


(Isa V) #1

Briefly describe your issue below:
Hi

New to the community.

I’ve tried probably the entire evening trying to install the drivers, but with no luck.

I used successfully used the CD on my Windows laptop and it installed fine. But using the files downloaded from the site provided for the dongle on my desktop with Parrot installed I get an “error 2” when trying to make. The file even comes with a install.sh however that also doesn’t work.

All the places I’ve managed to come across are for the 8812 and 8814 but struggling to even find a github for this version.

I connected to the internet using a Bluetooth dongle and tethering to my Samsung s8, before this I moved my desktop over to my Ethernet and did apt-get and apt-upgrade, and all sorts. I did the 88xxau dkms and that didn’t work (followed a YouTube video).

I’m quite new to Linux as a whole so I’ve had to read through forums and follow the code, so if you need some sort of info please let me know the only one I’ve retained is ifconfig and dkms status.

Hope you can help, I looked for another question like mine and the closest was 8812, but that’s the wrong driver.


What version of Parrot are you running? (include version, edition, and architecture)

I downloaded the latest one and installed via USB, I’ve had my desktop built completely for 1 week from Sunday.

What method did you use to install Parrot? Debian GTK i think!?

Configured to multiboot with other systems? no

If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:


(Nico Paul) #2

What is the device that is the adapter? Realtek has been unfavored as of late because of the complete 180 from just always works to almost never works it seems, at least for a few of the popular awus models. TP link v1 that is also common is favored by many here, including i believe SUDOBOSS himself, @palinuro


(gusmagna) #3

Hi,
In my early days with Linux I had troubles with the wifi-drivers (Realtek) on a Lenovo Thinkpad E470. Even though it was the distro Ubuntu, it is also a debian distro, like Parrot, so maybe it could be worthwhile of checking out the following link:

https://bbs.archlinux.org/viewtopic.php?id=229651

If you scroll down completely on the page and follow the suggested steps 1-5, that might work for you to get your wifi to work. It worked for me at least. Hope this was helpful and works for you!


(Isa V) #4

Thanks for the reply and info, I’ll try this out and update on the results


(Isa V) #5

Ok bear with me, I think what you want to know is

11AC
2.4G/5.8G
RTL8811AU
AC600

That’s all the info I’ve got, company name is ANEWish

Bought it from Amazon, I’ve emailed the seller, they sent me a file with instructions but stated it was for Ubuntu, now wants my email to send me a file


(gusmagna) #6

Hi,
Ok, so the RTL8811AU is the chipset you use on row 5 (see below) after you have downloaded the right driver from the manufacturer.

  1. Unpack zip archive.
  2. Change the Makefile. Line “export TopDIR ?= …” to export “TopDIR ?= PATH TO EXTRACTED DIRECTORY”.
  3. make
  4. sudo make install
  5. sudo modprobe -a 8821ce

Are you familiar with the command: sudo lshw ? If you try that you will see a lot of valuable information about your computer system.


(gusmagna) #7

Hi again,
If you cannot find the wifidrivers for linux, you could use windows drivers along with Ndis wrapper: https://wiki.debian.org/NdisWrapper

However, for this to work I think you have to have windows on a separate partition on your laptop. I never had to use it on my other laptop (Lenovo Thinkpad), because I got the Realtek drivers and was successful, when executing step 1-5 in the guide provided before. So if you have windows on a second partition, that can be the way to get your wifi to work with parrot.


(Isa V) #11

make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.18.0-parrot10-amd64/build M=/home/abuluqmaan/Downloads/rtl8821ce modules
make[1]: Entering directory ‘/usr/src/linux-headers-4.18.0-parrot10-amd64’
CC [M] /home/abuluqmaan/Downloads/rtl8821ce/os_dep/linux/os_intfs.o
/home/abuluqmaan/Downloads/rtl8821ce/os_dep/linux/os_intfs.c:1325:22: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
.ndo_select_queue = rtw_select_queue,
^~~~~~~~~~~~~~~~
/home/abuluqmaan/Downloads/rtl8821ce/os_dep/linux/os_intfs.c:1325:22: note: (near initialization for ‘rtw_netdev_ops.ndo_select_queue’)
cc1: some warnings being treated as errors
make[4]: *** [/usr/src/linux-headers-4.18.0-parrot10-common/scripts/Makefile.build:323: /home/abuluqmaan/Downloads/rtl8821ce/os_dep/linux/os_intfs.o] Error 1
make[3]: *** [/usr/src/linux-headers-4.18.0-parrot10-common/Makefile:1531: module/home/abuluqmaan/Downloads/rtl8821ce] Error 2
make[2]: *** [Makefile:146: sub-make] Error 2
make[1]: *** [Makefile:8: all] Error 2
make[1]: Leaving directory ‘/usr/src/linux-headers-4.18.0-parrot10-amd64’
make: *** [Makefile:1902: modules] Error 2

Blockquote
So i managed to get to a point, i even edited another file via these instructions
https://github.com/gnab/rtl8812au/pull/91/commits/a242ac2f4317b7532378a0a3afb53e330b70a7fb

And everything ran ok, no errors, when i run the
sudo modprobe -a 8821ce

it enters, then starts a new command line, but there are no returns from running that, which is the last part.

I’ve reset my desktop and plugged in the adapter, still nothing?!


(gusmagna) #12

Hi,
So, did you figure out how to modify the “makefile”? Should be quite straightforward after you have done that. Then you have to cd to the makefile and execute the “make” command.


(Isa V) #13

Hi

Yes, did all that, changed the make file, even tried changing another file as per the above link as I was getting another error. It’s ran all the way through, but i dont see my wifi networks, I’ve tried 3 ports. I’m new to parrot so not sure if there is somewhere else I can check if the adapter has been recognised at all?


(Nico Paul) #14

Did you also modprobe it after? Yes using iwconfig and iw dev if you read the man pages it will tell you how to issue the commands to see what driver it is using but you can also use lsusb if it is a USB one. Realtek has had issues lately so it may also be that


(Isa V) #15

Hi

So i used lsusb and it shows me the adapter
c811 Realtek Semiconductor Corp
But connections it isn’t showing still, least I know the USB port is working lol


(Isa V) #16

Ok… dont be annoyed, and I dont now know which solution worked but i got another adapter from another company, plugged it in, and this damn thing is now working!!! It’s the same make but a different company name, so I’ll contact the 1st adapter company and get a replacement

I did several things and I’m not unsure which one worked. I found another wifi thread with a solution in here which I’ll post too in case anyone comes across this. I’d like to thank you all for your help, appreciate the time taken to try and guide me through the setup.

solution i used last: Wlan0 doesn't exist. Wifi won't connect


(Nico Paul) #17

haha no one is annoyed no worries. glad you got it working. so it supports packet injection completely? can you post the model and make of the adapter with the driver you are using so I may test it and hopefully add it to the list of supported devices?


(Isa V) #18

Hi

I’ve not tried the pack injection yet, I’m new to ethical hacking, I was previously using a dongle that I don’t think supported it and was only 2.4ghz. This one is dual and supports monitor mode

Model: ANEWISH
VER: Realtek USB adapter
11AC

I bought it from Amazon, I’ve posted the link below

CUGLB Wifi Dongle High Speed… https://www.amazon.co.uk/dp/B07K1349TR?ref=yo_pop_ma_swf

Thanks for all the help, I’m returning the other one that isn’t working, I’ve tried everything and even got more drivers from the seller (also amazon) still wouldn’t ‘turn on’ and wouldn’t recognise networks or even show in my network connections.