Help installing parrot

Briefly describe your issue below:
i installed parrot os on a partition but it doesn’t open. it just boots up the Windows screen. i have tried reinstalling the software a lot of times, but it doesn’t boot.

What version of Parrot are you running? (include version, edition, and architecture)
parrot security 4.1
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
Debian GTK with a bootable USB
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:

If there are any error messages or relevant logs, post them below:

check your bios
check if the fast boot is disabled
check if the secure boot is disabled
check in bios and try to use boot in legacy mode.
then check in the forum for grub installation issues on uefi/efi

1 Like

I’m guessing your using windows 10… on a laptop… F9 for boot priority… I think… will check that out , well you can … depending on your system…
if ya got win 10 … go to settings. update and security… recovery… (tab left hand side)
Advanced start up… choose a device… that will show you the partition with your parrot os… and you should be able to boot into it… that is if you have installed it as uefi…

As elwood posted… bios settings… and uncheck fast boot in win… let us know what you find… will be helpful to others… cheers

1 Like


P.S btw i saw here many new people in the support ticket that they have some issue with grub and uefi/efi partition. After YOU check the bios secure/fast disable, if you have some issues with configure efi partition and so on, the dirty but working method is install parrot without grub and using grub2win. (i know most users It might put noses out of joint) IS a only a PERSONAL ADVICE, BUT if you are NEW this can help a lot.

  • in the parrot installation choose to not install grub:

  • install grub2win on windows

After install grub2win on windows:

  • if you are newbie read the GRUB2WIN INSTRUCTIONS FIRST!!!

  • manage EFI partition modules and set efi partition module (check the instructions)

  • on grub2win press the button manage mode manage boot

  • create new entry debian

  • delete on linux boots param the standard “verbose nomodeset” (it should change anyway if you follow instructions for custom mode anyway)

  • on new entry check the button “i will enter my custom configuration mode”

  • press the button edit custom load

  • grub2win open empty notepad page

then add

 set reviewpause=2
 set root='(hdZ,Z)'
 linux   /vmlinuz    root=/dev/sdaX   nouveau.modeset=0
 initrd  /initrd.img
 echo Grub will boot   Debian Linux
 echo Boot disk address is  $root
 echo The boot mode is      Partition Address
 sleep -i -v $reviewpause ; echo

in the set root=’(hdZ,Z)’ you must substitute the Z,Z with the disk and partition (can you check using ls on grub command line) for example (hd1,7) disk 1 partition 7
and in root=/dev/sdaX you must substitute the X with your parrot os partition is (sda6, sda7… and so on)
the string nouveau.modeset=0 is optional (if you are some issue with proprietary video card drivers)

  • save the configuration on grub2win
  • relaunch grub2win for check is the new entry is there
  • at boot choose debian linux
  • done
  • LESS troubles on windows 7/8/10 for dual boot installations
    i hope that this it might help you to fix a trouble with efi/uefi in windows
    unfortunately uefi/efi is a general issue in linux
1 Like