Help!! System won't wake up from sleep/hibernation

Hello everyone,

Lupin here I seem to be having a problem with my system and was hoping someone might have figured out a solution to this problem. I have done some research and can’t seem to see if anyone has actually resolved the issue. So basically what happens is when I put my PC to sleep or hibernate and go to rewake it the screen just stays black and I am unable to pull up even the terminal menu via (ctrl+alt+f1-f6) and at that point I have to hold the power button forcing a restart. So any information is appricated thank you in advance.

Could it be a partion issue?

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
I am currently running the latest version 4.7 on an amd64
What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)
I used a USB loaded via rufus 3.8
Configured to multiboot with other systems? (yes / no)
If there are any similar issues or solutions, link to them below:
If there are any error messages or relevant logs, post them below:

there may be an issue related to your graphics card (usually the case in these types of black screen no ‘wake up’ issues).

What kind of graphics card do you have?

Also: what have you already tried so it isn’t repeated?

thanks and Welcome to the forum!

That’s kind of where I was leaning, but what kind of steered me away from that idea it, prior to installing parrot and when I was solely running windows 10 I had no problem ‘waking up’ the pc. Maybe it’s a compatible thing? In running a radeon r5 got a graphics card.

Let me put together a list of things I’ve tried but honestly I’m open for anything will retry anything again

It could be a general Linux driver kernel compatability problem: you could try an earlier Kernel… wouldn’t go through too much trouble installing multiple Kernels.

I have a couple ideas for you :grin:

Temporary solution to use as long as you like:
In power management (little battery/power icon in corner of screen). scroll down to Preferences. Turn off all settings related to suspend/hibernate mode (read them carefully to make sure all rules do not enable).

You could try manually setting short wait sleep mode to see if it creates new errors if you don’t mind possibly having to reboot a couple times. If this is a sleep mode related problem this will allow you to close the lid/walk away until we figure this out.

If you want to find out if it is a graphics card issue you can try the following:

cat /var/log/syslog|grep 'sleep'

to see the times your laptop went to sleep. Take note of the times.

Next, scroll through /var/log/ looking for errors that are within a few min of those sleep times. If you find anything that match the time range between when your laptop went to sleep, and when you opened it up, you can paste them here so we can see them.

If you do paste a log here, highlight the text. Then use the </> button to format it in the reply (do not paste the entire log-- just the errors/fails). If you want to share the entire log (if you are not sure about errors) use something like pastebin.

1 Like

I am experiencing similar problems with Parrot 4.7 on Macbook Air - refuses to wake up from sleep mode - its even worse than me in the mornings- although I get a different type of boot!

Checked syslog for sleep times and also for errors around those times, no errors, so assume its not graphic card. Like Sean, I have no problems if I run it back on OS-X, its just when using Parrot that this problem arises. I have changed settings in Power Management so it never goes to sleep, its a temporary solution.

I had similar problem because I was experiencing screen tearing with kernel 5.3… So I installed Compton and after that enable it through System-Mate Tweak-Widows-Window Manager
adn select: Marco (Compton GPU compositor)

5.x kernels brought some big changes & along with that, some hardware issues. Could be related to that.

Could continue looking through various /var/log logfiles for unusual events (especially kernel msgs) after sleep time start. Or just wait it out.

Luckily, Linux Kernel devs always get around to fixing these kinds of issues eventually. Unfortunately macbook users make up the minority of users so there are less testers/reported bugs.

As with everything, I am sure it will get fixed once someone narrows it down for devs. Kernel 5.x hardware compatibility issues are across the board for all Linux distros.

Possible Solution:
If you decide you want to try to use sleep mode, you guys could also try installing an older 4.x Kernel and see if the problem remains. In fact I always recommend keeping an older kernel for when these types of (possibly) Kernel issues arise :slightly_smiling_face:

I have been able to find this in /var/log/kern.log being the last entry after trying to wake it up and before hard reboot. I think this is the WiFi card being silly?

:ERROR @wl_cfg80211_scan
:WLC_SCAN error (-22)

Running on the older kernal solves the problem, it wakes from sleep and hinernate just fine on the 4.x version. I will take your advise and await bug fixes to 5.x - or is there some preferred way to submit this issue?

1 Like

Glad to hear running the earlier kernel worked out :slight_smile:
If you do narrow it down here and still want to report it, bug reporting guide for kernel issue (keep in mind they expect bug reporters to follow up etc):

Sorry, thought I had already replied! :slight_smile:

Oh yes this is msg you saw is wireless related. Related to when in sleep/hibernate mode your laptop disconnects from WiFi and unrelated to screen issue.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.