Help with Realtek wlan driver

Briefly describe your issue below:
Fresh install today and my Realtek RTL8723DE 802.11b/g/n PCIe Adapter [10EC:D723] wireless card will not work. i’ve been across reddit, stackexchange, and a few dozen other forums looking for an answer and recieved nothing. I’ve tried avoiding coming here because I’m sure you’ve all had to help with this countless times and I didn’t want to be a bother, but nothing works.

What version of Parrot are you running? V4.10,
edition: Parrot-Security MATE
and architecture: amdX64

What method did you use to install Parrot? USB disk

Configured to multiboot with other systems? no

If there are any similar issues or solutions, link to them below:
none that I’ve encountered yet.
If there are any error messages or relevant logs, post them below:
Termbin log
https://termbin.com/jtvm
Picture of Hardware Lister’s info on the driver:
https://tinyurl.com/ParrotOS-hardwarelister

Thank you in advance for any/all assistance.

Thanks for including so much information :slight_smile:

I ran this card a while back on one of the 4* Kernels.

The current driver for Linux Kernel 5+ is smlinux.

Install instructions from the page:

git clone https://github.com/smlinux/rtl8723de.git -b current
dkms add ./rtl8723de
dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
depmod -a
reboot

You can find the driver here:

1 Like

Oh my God. You’re a saint, thank you so much, this was driving me crazy, lol.

1 Like

no problem :slight_smile:

The above solution has issues so here is some