Hex Squares

Briefly describe your issue below:
When i open konsole as root the pop up which asks for my password is written in Hex Squares same as when i open pictures the text is written in Hex Squares. Its not every software for example Kwrite and Dolphin work fine. Also i checked my locale they are all set to “en_US.UTF-8”. here’s a picture on how it looks i just found out when i open Tilix from konsole with sudo tilix it works but when i open it via icon it show the hex squares.

What version of Parrot are you running? (include version (e.g. 4.6), edition(e.g. Home//KDE/OVA, etc.), and architecture (currently we only support amd64)
Security 5.5.0-1parrot1-amd64

What method did you use to install Parrot? (Debian Standard / Debian GTK / parrot-experimental)

Configured to multiboot with other systems? (yes / no)

If there are any similar issues or solutions, link to them below:
i found nothing on the Internet or in this forum. or at least not under the title Hex Squares.

If there are any error messages or relevant logs, post them below:
i looked into the logs because someone on Discord said it may help but since i’m pretty new to linux i dont know that to look for. And There are no Error Messages at all everything works fine

its because of broken font packages
try using other fonts
that will fix the issue

1 Like

try changing font OR reinstall font package & sudo parrot-upgrade

1 Like

it worked. i wasn’t sure how to fix it since parrot-upgrade didn’t worked and when i changed the system font it changed back to bitstream (the problem font) automatically. I found a fix here Parrot 4.9 Bug Report in case someone else has the same problem.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.