How can i change interface name

Hi everyone


My wifi interface name is wlx…

İ want to change name wlan0

How can i do this


There has been a change in the way Linux handles naming devices “for more reliable names” (based on mac address) for scripting and such.

Please always search before posting to avoid double posting.

There are a few posts on this: Rename ridiculous interface name to wlan0 ?

In short, try this:

sudo ln -s /dev/null /etc/udev/rules.d/80-net-setup-link.rules

Then reboot.

1 Like

thank you so much. This is perfect solution

1 Like

I recently had to do the same. One of my Raspberry pi’s kept conflicting in saved networks. There seemed to be some instability where it first takes usb0, then on (attempting) reconnect changed to longer, mac address based name. This caused issues on multiple fronts for what I was doing,

I get the theory behind it: stability in names for writing scripts. Multiple devices can interchange/take on multiple names (depending which recognized first at that moment) from wlan0, wlan1, wlan2, etc.

Anyhow, glad this worked for you. :grin:

Hello again

It was really a great solution to change names but since I did this I cannot connect to the WIFI network.

How can I restore it, can you help me?

Can you help me give me a code like this and undo the action I made?

I think my interface name will have to remain the same, thank you.

sudo unlink 80-net-setup-link.rules

This is correct to undo changes ?

execute in /etc/udev/rules.d/

Finally, I restored this process with the unlock code I specified, I installed the drivers again, but this time the interface turns itself off when monitor mode is turned on. Do I need to make a different setting? Thank you.

unlink reverses/removes the link to /dev/null.

What do you mean turns off? Using airmon-ng?

iwconfig should allow you to change your interface name.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.