How can I enable SSH service?

Briefly describe your issue below:

I got this message while I want to enable SSH service:
#systemctl enable ssh
Syncronising state of ssh.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable ssh
insserv: Script ntp has overlapping Default-Start and Default-Stop runlevels (2 3 4 5) and (2 3 4 5). This should be fixed.
insserv: Script ntp has overlapping Default-Start and Default-Stop runlevels (2 3 4 5) and (2 3 4 5). This should be fixed.

What version of Parrot are you running? 4.9.1

What method did you use to install Parrot? Install from Live system

Configured to multiboot with other systems? I have not any other OS

try this:

sudo systemctl enable ssh
sudo systemctl start ssh

Should work :slight_smile:

[user@Parrot]─[~]
└──╼ $sudo systemctl enable ssh
[sudo] password for user:
Synchronizing state of ssh.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable ssh
insserv: warning: current start runlevel(s) (empty) of script ssh' overrides LSB defaults (2 3 4 5). insserv: warning: current stop runlevel(s) (2 3 4 5) of script ssh’ overrides LSB defaults (empty).
insserv: Script ssh has overlapping Default-Start and Default-Stop runlevels (2 3 4 5) and (2 3 4 5). This should be fixed.
insserv: Script ntp has overlapping Default-Start and Default-Stop runlevels (2 3 4 5) and (2 3 4 5). This should be fixed.
insserv: Script ntp has overlapping Default-Start and Default-Stop runlevels (2 3 4 5) and (2 3 4 5). This should be fixed.
Created symlink /etc/systemd/system/sshd.service → /lib/systemd/system/ssh.service.
Created symlink /etc/systemd/system/multi-user.target.wants/ssh.service → /lib/systemd/system/ssh.service.
┌─[user@Parrot]─[~]
└──╼ $sudo systemctl start ssh
Job for ssh.service failed because the control process exited with error code.
See “systemctl status ssh.service” and “journalctl -xe” for details.
┌─[✗]─[user@Parrot]─[~]
└──╼ $

sooo… did you:

See “systemctl status ssh.service” and “journalctl -xe” for details.

?

No!
I want to use Parrot Security for the penetration test, So I have not any time to debug this distro while it using the testing version of Debian.